==========================================================================
Ubuntu Security Notice USN-6483-1
November 15, 2023

tidy-html5 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

tidy-html5 could be made to crash or run programs if it opened a specially
crafted file.

Software Description:
- tidy-html5: HTML/XML syntax checker and reformatter

Details:

Neeraj Pal discovered that HTML Tidy incorrectly handled parsing certain
HTML data. If a user or automated system were tricked into parsing
specially crafted HTML data, a remote attacker could cause HTML Tidy to
consume resources, leading to a denial of service, or possibly execute
arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
   libtidy5deb1                    2:5.6.0-11ubuntu0.23.10.1
   tidy                            2:5.6.0-11ubuntu0.23.10.1

Ubuntu 23.04:
   libtidy5deb1                    2:5.6.0-11ubuntu0.23.04.1
   tidy                            2:5.6.0-11ubuntu0.23.04.1

Ubuntu 22.04 LTS:
   libtidy5deb1                    2:5.6.0-11ubuntu0.22.04.1
   tidy                            2:5.6.0-11ubuntu0.22.04.1

Ubuntu 20.04 LTS:
   libtidy5deb1                    2:5.6.0-11ubuntu0.20.04.1
   tidy                            2:5.6.0-11ubuntu0.20.04.1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6483-1
   CVE-2021-33391

Package Information:
   https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.23.10.1
   https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.23.04.1
   https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.22.04.1
   https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.20.04.1

Ubuntu 6483-1: HTML Tidy vulnerability

November 15, 2023
tidy-html5 could be made to crash or run programs if it opened a specially crafted file.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 23.10 - Ubuntu 23.04 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS Summary: tidy-html5 could be made to crash or run programs if it opened a specially crafted file. Software Description: - tidy-html5: HTML/XML syntax checker and reformatter Details: Neeraj Pal discovered that HTML Tidy incorrectly handled parsing certain HTML data. If a user or automated system were tricked into parsing specially crafted HTML data, a remote attacker could cause HTML Tidy to consume resources, leading to a denial of service, or possibly execute arbitrary code.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 23.10: libtidy5deb1 2:5.6.0-11ubuntu0.23.10.1 tidy 2:5.6.0-11ubuntu0.23.10.1 Ubuntu 23.04: libtidy5deb1 2:5.6.0-11ubuntu0.23.04.1 tidy 2:5.6.0-11ubuntu0.23.04.1 Ubuntu 22.04 LTS: libtidy5deb1 2:5.6.0-11ubuntu0.22.04.1 tidy 2:5.6.0-11ubuntu0.22.04.1 Ubuntu 20.04 LTS: libtidy5deb1 2:5.6.0-11ubuntu0.20.04.1 tidy 2:5.6.0-11ubuntu0.20.04.1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-6483-1

CVE-2021-33391

Severity
Ubuntu Security Notice USN-6483-1

Package Information

https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.23.10.1 https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.23.04.1 https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.22.04.1 https://launchpad.net/ubuntu/+source/tidy-html5/2:5.6.0-11ubuntu0.20.04.1

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo