# Security update for slurm_22_05

Announcement ID: SUSE-SU-2023:4581-1  
Rating: important  
References:

  * bsc#1208810
  * bsc#1216207
  * bsc#1216869

  
Cross-References:

  * CVE-2023-41914

  
CVSS scores:

  * CVE-2023-41914 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
  * CVE-2023-41914 ( NVD ):  7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 15 SP1
  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1

  
  
An update that solves one vulnerability and has two security fixes can now be
installed.

## Description:

This update for slurm_22_05 fixes the following issues:

  * CVE-2023-41914: Fixed a filesystem handling race condition that could have
    led to an attacker taking control of an arbitrary file, or removing entire
    directory contents (bsc#1216207).

Bug fixes:

  * Add missing dependencies to slurm-config to plugins package. These should
    help to tie down the slurm version and help to avoid a package mix
    (bsc#1216869).
  * Add missing Provides:, Conflicts: and Obsoletes: to slurm-cray, slurm-hdf5
    and slurm-testsuite to avoid package conflicts (bsc#1208810).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4581=1

## Package List:

  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (aarch64
    x86_64)
    * perl-slurm_22_05-22.05.10-150100.3.6.1
    * libslurm38-22.05.10-150100.3.6.1
    * slurm_22_05-slurmdbd-22.05.10-150100.3.6.1
    * slurm_22_05-lua-22.05.10-150100.3.6.1
    * slurm_22_05-sview-22.05.10-150100.3.6.1
    * slurm_22_05-sql-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-22.05.10-150100.3.6.1
    * libnss_slurm2_22_05-22.05.10-150100.3.6.1
    * libslurm38-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-devel-22.05.10-150100.3.6.1
    * slurm_22_05-pam_slurm-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-plugins-22.05.10-150100.3.6.1
    * slurm_22_05-munge-22.05.10-150100.3.6.1
    * slurm_22_05-rest-22.05.10-150100.3.6.1
    * slurm_22_05-torque-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-pam_slurm-22.05.10-150100.3.6.1
    * slurm_22_05-rest-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-debugsource-22.05.10-150100.3.6.1
    * slurm_22_05-torque-22.05.10-150100.3.6.1
    * libpmi0_22_05-debuginfo-22.05.10-150100.3.6.1
    * libnss_slurm2_22_05-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-slurmdbd-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-plugins-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-auth-none-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-munge-debuginfo-22.05.10-150100.3.6.1
    * perl-slurm_22_05-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-lua-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-node-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-sql-22.05.10-150100.3.6.1
    * slurm_22_05-debuginfo-22.05.10-150100.3.6.1
    * libpmi0_22_05-22.05.10-150100.3.6.1
    * slurm_22_05-sview-debuginfo-22.05.10-150100.3.6.1
    * slurm_22_05-node-22.05.10-150100.3.6.1
    * slurm_22_05-auth-none-22.05.10-150100.3.6.1
  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (noarch)
    * slurm_22_05-doc-22.05.10-150100.3.6.1
    * slurm_22_05-webdoc-22.05.10-150100.3.6.1
    * slurm_22_05-config-man-22.05.10-150100.3.6.1
    * slurm_22_05-config-22.05.10-150100.3.6.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-41914.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1208810
  * https://bugzilla.suse.com/show_bug.cgi?id=1216207
  * https://bugzilla.suse.com/show_bug.cgi?id=1216869

SUSE: 2023:4581-1 important: slurm_22_05

November 27, 2023
* bsc#1208810 * bsc#1216207 * bsc#1216869 Cross-References:

Summary

## This update for slurm_22_05 fixes the following issues: * CVE-2023-41914: Fixed a filesystem handling race condition that could have led to an attacker taking control of an arbitrary file, or removing entire directory contents (bsc#1216207). Bug fixes: * Add missing dependencies to slurm-config to plugins package. These should help to tie down the slurm version and help to avoid a package mix (bsc#1216869). * Add missing Provides:, Conflicts: and Obsoletes: to slurm-cray, slurm-hdf5 and slurm-testsuite to avoid package conflicts (bsc#1208810). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4581=1 ## Package List: * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (aarch64 x86_64) * perl-slurm_22_05-22.05.10-150100.3.6.1 * libslurm38-22.05.10-150100.3.6.1 * slurm_22_05-slurmdbd-22.05.10-150100.3.6.1 * slurm_22_05-lua-22.05.10-150100.3.6.1 * slurm_22_05-sview-22.05.10-150100.3.6.1 * slurm_22_05-sql-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-22.05.10-150100.3.6.1 * libnss_slurm2_22_05-22.05.10-150100.3.6.1 * libslurm38-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-devel-22.05.10-150100.3.6.1 * slurm_22_05-pam_slurm-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-plugins-22.05.10-150100.3.6.1 * slurm_22_05-munge-22.05.10-150100.3.6.1 * slurm_22_05-rest-22.05.10-150100.3.6.1 * slurm_22_05-torque-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-pam_slurm-22.05.10-150100.3.6.1 * slurm_22_05-rest-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-debugsource-22.05.10-150100.3.6.1 * slurm_22_05-torque-22.05.10-150100.3.6.1 * libpmi0_22_05-debuginfo-22.05.10-150100.3.6.1 * libnss_slurm2_22_05-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-slurmdbd-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-plugins-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-auth-none-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-munge-debuginfo-22.05.10-150100.3.6.1 * perl-slurm_22_05-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-lua-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-node-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-sql-22.05.10-150100.3.6.1 * slurm_22_05-debuginfo-22.05.10-150100.3.6.1 * libpmi0_22_05-22.05.10-150100.3.6.1 * slurm_22_05-sview-debuginfo-22.05.10-150100.3.6.1 * slurm_22_05-node-22.05.10-150100.3.6.1 * slurm_22_05-auth-none-22.05.10-150100.3.6.1 * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (noarch) * slurm_22_05-doc-22.05.10-150100.3.6.1 * slurm_22_05-webdoc-22.05.10-150100.3.6.1 * slurm_22_05-config-man-22.05.10-150100.3.6.1 * slurm_22_05-config-22.05.10-150100.3.6.1

References

* bsc#1208810

* bsc#1216207

* bsc#1216869

Cross-

* CVE-2023-41914

CVSS scores:

* CVE-2023-41914 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

* CVE-2023-41914 ( NVD ): 7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Linux Enterprise High Performance Computing 15 SP1

* SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1

An update that solves one vulnerability and has two security fixes can now be

installed.

##

* https://www.suse.com/security/cve/CVE-2023-41914.html

* https://bugzilla.suse.com/show_bug.cgi?id=1208810

* https://bugzilla.suse.com/show_bug.cgi?id=1216207

* https://bugzilla.suse.com/show_bug.cgi?id=1216869

Severity
Announcement ID: SUSE-SU-2023:4581-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo