# Security update for frr

Announcement ID: SUSE-SU-2023:4473-1  
Rating: moderate  
References:

  * bsc#1216626
  * bsc#1216627

  
Cross-References:

  * CVE-2023-46752
  * CVE-2023-46753

  
CVSS scores:

  * CVE-2023-46752 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2023-46752 ( NVD ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2023-46753 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2023-46753 ( NVD ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

  
Affected Products:

  * openSUSE Leap 15.5
  * Server Applications Module 15-SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5

  
  
An update that solves two vulnerabilities can now be installed.

## Description:

This update for frr fixes the following issues:

  * CVE-2023-46753: Fixed a crash caused from a crafted BGP UPDATE message.
    (bsc#1216626)
  * CVE-2023-46752: Fixed a crash caused from a mishandled malformed
    MP_REACH_NLRI data. (bsc#1216627)

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.5  
    zypper in -t patch SUSE-2023-4473=1 openSUSE-SLE-15.5-2023-4473=1

  * Server Applications Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP5-2023-4473=1

## Package List:

  * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586)
    * libmlag_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrzmq0-8.4-150500.4.11.1
    * libfrrfpm_pb0-8.4-150500.4.11.1
    * frr-debuginfo-8.4-150500.4.11.1
    * libfrrcares0-debuginfo-8.4-150500.4.11.1
    * libfrrfpm_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrospfapiclient0-8.4-150500.4.11.1
    * libfrrzmq0-debuginfo-8.4-150500.4.11.1
    * libfrr_pb0-8.4-150500.4.11.1
    * libmlag_pb0-8.4-150500.4.11.1
    * frr-debugsource-8.4-150500.4.11.1
    * frr-8.4-150500.4.11.1
    * libfrr_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrsnmp0-8.4-150500.4.11.1
    * libfrr0-debuginfo-8.4-150500.4.11.1
    * libfrrospfapiclient0-debuginfo-8.4-150500.4.11.1
    * libfrrcares0-8.4-150500.4.11.1
    * libfrrsnmp0-debuginfo-8.4-150500.4.11.1
    * frr-devel-8.4-150500.4.11.1
    * libfrr0-8.4-150500.4.11.1
  * Server Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libmlag_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrzmq0-8.4-150500.4.11.1
    * libfrrfpm_pb0-8.4-150500.4.11.1
    * frr-debuginfo-8.4-150500.4.11.1
    * libfrrcares0-debuginfo-8.4-150500.4.11.1
    * libfrrfpm_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrospfapiclient0-8.4-150500.4.11.1
    * libfrrzmq0-debuginfo-8.4-150500.4.11.1
    * libfrr_pb0-8.4-150500.4.11.1
    * libmlag_pb0-8.4-150500.4.11.1
    * frr-debugsource-8.4-150500.4.11.1
    * frr-8.4-150500.4.11.1
    * libfrr_pb0-debuginfo-8.4-150500.4.11.1
    * libfrrsnmp0-8.4-150500.4.11.1
    * libfrr0-debuginfo-8.4-150500.4.11.1
    * libfrrospfapiclient0-debuginfo-8.4-150500.4.11.1
    * libfrrcares0-8.4-150500.4.11.1
    * libfrrsnmp0-debuginfo-8.4-150500.4.11.1
    * frr-devel-8.4-150500.4.11.1
    * libfrr0-8.4-150500.4.11.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-46752.html
  * https://www.suse.com/security/cve/CVE-2023-46753.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1216626
  * https://bugzilla.suse.com/show_bug.cgi?id=1216627

SUSE: 2023:4473-1 moderate: frr

November 17, 2023
* bsc#1216626 * bsc#1216627 Cross-References: * CVE-2023-46752

Summary

## This update for frr fixes the following issues: * CVE-2023-46753: Fixed a crash caused from a crafted BGP UPDATE message. (bsc#1216626) * CVE-2023-46752: Fixed a crash caused from a mishandled malformed MP_REACH_NLRI data. (bsc#1216627) ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.5 zypper in -t patch SUSE-2023-4473=1 openSUSE-SLE-15.5-2023-4473=1 * Server Applications Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP5-2023-4473=1 ## Package List: * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586) * libmlag_pb0-debuginfo-8.4-150500.4.11.1 * libfrrzmq0-8.4-150500.4.11.1 * libfrrfpm_pb0-8.4-150500.4.11.1 * frr-debuginfo-8.4-150500.4.11.1 * libfrrcares0-debuginfo-8.4-150500.4.11.1 * libfrrfpm_pb0-debuginfo-8.4-150500.4.11.1 * libfrrospfapiclient0-8.4-150500.4.11.1 * libfrrzmq0-debuginfo-8.4-150500.4.11.1 * libfrr_pb0-8.4-150500.4.11.1 * libmlag_pb0-8.4-150500.4.11.1 * frr-debugsource-8.4-150500.4.11.1 * frr-8.4-150500.4.11.1 * libfrr_pb0-debuginfo-8.4-150500.4.11.1 * libfrrsnmp0-8.4-150500.4.11.1 * libfrr0-debuginfo-8.4-150500.4.11.1 * libfrrospfapiclient0-debuginfo-8.4-150500.4.11.1 * libfrrcares0-8.4-150500.4.11.1 * libfrrsnmp0-debuginfo-8.4-150500.4.11.1 * frr-devel-8.4-150500.4.11.1 * libfrr0-8.4-150500.4.11.1 * Server Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libmlag_pb0-debuginfo-8.4-150500.4.11.1 * libfrrzmq0-8.4-150500.4.11.1 * libfrrfpm_pb0-8.4-150500.4.11.1 * frr-debuginfo-8.4-150500.4.11.1 * libfrrcares0-debuginfo-8.4-150500.4.11.1 * libfrrfpm_pb0-debuginfo-8.4-150500.4.11.1 * libfrrospfapiclient0-8.4-150500.4.11.1 * libfrrzmq0-debuginfo-8.4-150500.4.11.1 * libfrr_pb0-8.4-150500.4.11.1 * libmlag_pb0-8.4-150500.4.11.1 * frr-debugsource-8.4-150500.4.11.1 * frr-8.4-150500.4.11.1 * libfrr_pb0-debuginfo-8.4-150500.4.11.1 * libfrrsnmp0-8.4-150500.4.11.1 * libfrr0-debuginfo-8.4-150500.4.11.1 * libfrrospfapiclient0-debuginfo-8.4-150500.4.11.1 * libfrrcares0-8.4-150500.4.11.1 * libfrrsnmp0-debuginfo-8.4-150500.4.11.1 * frr-devel-8.4-150500.4.11.1 * libfrr0-8.4-150500.4.11.1

References

* bsc#1216626

* bsc#1216627

Cross-

* CVE-2023-46752

* CVE-2023-46753

CVSS scores:

* CVE-2023-46752 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2023-46752 ( NVD ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2023-46753 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2023-46753 ( NVD ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

* openSUSE Leap 15.5

* Server Applications Module 15-SP5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that solves two vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-46752.html

* https://www.suse.com/security/cve/CVE-2023-46753.html

* https://bugzilla.suse.com/show_bug.cgi?id=1216626

* https://bugzilla.suse.com/show_bug.cgi?id=1216627

Severity
Announcement ID: SUSE-SU-2023:4473-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo