# Security update for slurm

Announcement ID: SUSE-SU-2023:4118-1  
Rating: important  
References:

  * bsc#1208810
  * bsc#1216207

  
Cross-References:

  * CVE-2023-41914

  
CVSS scores:

  * CVE-2023-41914 ( SUSE ):  8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 15 SP1
  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1

  
  
An update that solves one vulnerability and has one security fix can now be
installed.

## Description:

This update for slurm fixes the following issues:

  * CVE-2023-41914: Fixed a filesystem handling race conditions that could lead
    to an attacker taking control of an arbitrary file. (bsc#1216207)

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4118=1

## Package List:

  * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (aarch64
    x86_64)
    * slurm_20_02-slurmdbd-20.02.7-150100.3.27.1
    * slurm_20_02-20.02.7-150100.3.27.1
    * slurm_20_02-webdoc-20.02.7-150100.3.27.1
    * libnss_slurm2_20_02-20.02.7-150100.3.27.1
    * slurm_20_02-node-20.02.7-150100.3.27.1
    * perl-slurm_20_02-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-auth-none-20.02.7-150100.3.27.1
    * slurm_20_02-devel-20.02.7-150100.3.27.1
    * slurm_20_02-sview-20.02.7-150100.3.27.1
    * libpmi0_20_02-20.02.7-150100.3.27.1
    * slurm_20_02-auth-none-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-torque-20.02.7-150100.3.27.1
    * slurm_20_02-sql-20.02.7-150100.3.27.1
    * slurm_20_02-config-man-20.02.7-150100.3.27.1
    * slurm_20_02-plugins-debuginfo-20.02.7-150100.3.27.1
    * libpmi0_20_02-debuginfo-20.02.7-150100.3.27.1
    * libslurm35-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-munge-20.02.7-150100.3.27.1
    * slurm_20_02-node-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-torque-debuginfo-20.02.7-150100.3.27.1
    * perl-slurm_20_02-20.02.7-150100.3.27.1
    * slurm_20_02-slurmdbd-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-sview-debuginfo-20.02.7-150100.3.27.1
    * libslurm35-20.02.7-150100.3.27.1
    * slurm_20_02-debugsource-20.02.7-150100.3.27.1
    * libnss_slurm2_20_02-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-plugins-20.02.7-150100.3.27.1
    * slurm_20_02-munge-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-sql-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-pam_slurm-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-lua-20.02.7-150100.3.27.1
    * slurm_20_02-pam_slurm-20.02.7-150100.3.27.1
    * slurm_20_02-doc-20.02.7-150100.3.27.1
    * slurm_20_02-lua-debuginfo-20.02.7-150100.3.27.1
    * slurm_20_02-config-20.02.7-150100.3.27.1
    * slurm_20_02-debuginfo-20.02.7-150100.3.27.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-41914.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1208810
  * https://bugzilla.suse.com/show_bug.cgi?id=1216207

SUSE: 2023:4118-1 important: slurm

October 18, 2023
* bsc#1208810 * bsc#1216207 Cross-References: * CVE-2023-41914

Summary

## This update for slurm fixes the following issues: * CVE-2023-41914: Fixed a filesystem handling race conditions that could lead to an attacker taking control of an arbitrary file. (bsc#1216207) ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2023-4118=1 ## Package List: * SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1 (aarch64 x86_64) * slurm_20_02-slurmdbd-20.02.7-150100.3.27.1 * slurm_20_02-20.02.7-150100.3.27.1 * slurm_20_02-webdoc-20.02.7-150100.3.27.1 * libnss_slurm2_20_02-20.02.7-150100.3.27.1 * slurm_20_02-node-20.02.7-150100.3.27.1 * perl-slurm_20_02-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-auth-none-20.02.7-150100.3.27.1 * slurm_20_02-devel-20.02.7-150100.3.27.1 * slurm_20_02-sview-20.02.7-150100.3.27.1 * libpmi0_20_02-20.02.7-150100.3.27.1 * slurm_20_02-auth-none-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-torque-20.02.7-150100.3.27.1 * slurm_20_02-sql-20.02.7-150100.3.27.1 * slurm_20_02-config-man-20.02.7-150100.3.27.1 * slurm_20_02-plugins-debuginfo-20.02.7-150100.3.27.1 * libpmi0_20_02-debuginfo-20.02.7-150100.3.27.1 * libslurm35-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-munge-20.02.7-150100.3.27.1 * slurm_20_02-node-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-torque-debuginfo-20.02.7-150100.3.27.1 * perl-slurm_20_02-20.02.7-150100.3.27.1 * slurm_20_02-slurmdbd-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-sview-debuginfo-20.02.7-150100.3.27.1 * libslurm35-20.02.7-150100.3.27.1 * slurm_20_02-debugsource-20.02.7-150100.3.27.1 * libnss_slurm2_20_02-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-plugins-20.02.7-150100.3.27.1 * slurm_20_02-munge-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-sql-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-pam_slurm-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-lua-20.02.7-150100.3.27.1 * slurm_20_02-pam_slurm-20.02.7-150100.3.27.1 * slurm_20_02-doc-20.02.7-150100.3.27.1 * slurm_20_02-lua-debuginfo-20.02.7-150100.3.27.1 * slurm_20_02-config-20.02.7-150100.3.27.1 * slurm_20_02-debuginfo-20.02.7-150100.3.27.1

References

* bsc#1208810

* bsc#1216207

Cross-

* CVE-2023-41914

CVSS scores:

* CVE-2023-41914 ( SUSE ): 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Linux Enterprise High Performance Computing 15 SP1

* SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS 15-SP1

An update that solves one vulnerability and has one security fix can now be

installed.

##

* https://www.suse.com/security/cve/CVE-2023-41914.html

* https://bugzilla.suse.com/show_bug.cgi?id=1208810

* https://bugzilla.suse.com/show_bug.cgi?id=1216207

Severity
Announcement ID: SUSE-SU-2023:4118-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo