SUSE Container Update Advisory: suse/sle15
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2023:2868-1
Container Tags        : suse/sle15:15.1 , suse/sle15:15.1.6.2.814
Container Release     : 6.2.814
Severity              : important
Type                  : security
References            : 1183533 1211945 1211946 1211947 1211948 1211951 1212475 CVE-2021-28153
                        CVE-2023-29499 CVE-2023-32611 CVE-2023-32636 CVE-2023-32643 CVE-2023-32665
-----------------------------------------------------------------

The container suse/sle15 was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:3535-1
Released:    Tue Sep  5 14:46:31 2023
Summary:     Security update for glib2
Type:        security
Severity:    important
References:  1183533,1211945,1211946,1211947,1211948,1211951,CVE-2021-28153,CVE-2023-29499,CVE-2023-32611,CVE-2023-32636,CVE-2023-32643,CVE-2023-32665
This update for glib2 fixes the following issues:

- CVE-2021-28153: Fixed an issue where symlink targets would be incorrectly created as empty files. (bsc#1183533)
- CVE-2023-32665: Fixed GVariant deserialisation which does not match spec for non-normal data. (bsc#1211945)
- CVE-2023-32643: Fixed a heap-buffer-overflow in g_variant_serialised_get_child(). (bsc#1211946)
- CVE-2023-29499: Fixed GVariant offset table entry size which is not checked in is_normal(). (bsc#1211947)
- CVE-2023-32636: Fixed a wrong timeout in fuzz_variant_text(). (bsc#1211948)
- CVE-2023-32611: Fixed an issue where g_variant_byteswap() can take a long time with some non-normal inputs. (bsc#1211951)

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2023:3539-1
Released:    Tue Sep  5 16:41:09 2023
Summary:     Security update for container-suseconnect
Type:        security
Severity:    important
References:  1212475

This update of container-suseconnect fixes the following issues:

- rebuild the package with the go 1.21 security release (bsc#1212475).


The following package changes have been done:

- container-suseconnect-2.4.0-150000.4.36.1 updated
- libglib-2_0-0-2.54.3-150000.4.29.1 updated

SUSE: 2023:2868-1 suse/sle15 Security Update

September 7, 2023
The container suse/sle15 was updated

Summary

Advisory ID: SUSE-SU-2023:3535-1 Released: Tue Sep 5 14:46:31 2023 Summary: Security update for glib2 Type: security Severity: important Advisory ID: SUSE-SU-2023:3539-1 Released: Tue Sep 5 16:41:09 2023 Summary: Security update for container-suseconnect Type: security Severity: important

References

References : 1183533 1211945 1211946 1211947 1211948 1211951 1212475 CVE-2021-28153

CVE-2023-29499 CVE-2023-32611 CVE-2023-32636 CVE-2023-32643 CVE-2023-32665

1183533,1211945,1211946,1211947,1211948,1211951,CVE-2021-28153,CVE-2023-29499,CVE-2023-32611,CVE-2023-32636,CVE-2023-32643,CVE-2023-32665

This update for glib2 fixes the following issues:

- CVE-2021-28153: Fixed an issue where symlink targets would be incorrectly created as empty files. (bsc#1183533)

- CVE-2023-32665: Fixed GVariant deserialisation which does not match spec for non-normal data. (bsc#1211945)

- CVE-2023-32643: Fixed a heap-buffer-overflow in g_variant_serialised_get_child(). (bsc#1211946)

- CVE-2023-29499: Fixed GVariant offset table entry size which is not checked in is_normal(). (bsc#1211947)

- CVE-2023-32636: Fixed a wrong timeout in fuzz_variant_text(). (bsc#1211948)

- CVE-2023-32611: Fixed an issue where g_variant_byteswap() can take a long time with some non-normal inputs. (bsc#1211951)

1212475

This update of container-suseconnect fixes the following issues:

- rebuild the package with the go 1.21 security release (bsc#1212475).

The following package changes have been done:

- container-suseconnect-2.4.0-150000.4.36.1 updated

- libglib-2_0-0-2.54.3-150000.4.29.1 updated

Severity
Container Advisory ID : SUSE-CU-2023:2868-1
Container Tags : suse/sle15:15.1 , suse/sle15:15.1.6.2.814
Container Release : 6.2.814
Severity : important
Type : security

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo