{"type":"TYPE_SECURITY","shortCode":"RL","name":"RLSA-2023:4539","synopsis":"Moderate: postgresql:10 security update","severity":"SEVERITY_MODERATE","topic":"An update is available for module.postgresql, postgresql.\nThis update affects Rocky Linux 8.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"PostgreSQL is an advanced object-relational database management system (DBMS).\n\nSecurity Fix(es):\n\n* postgresql: schema_element defeats protective search_path changes (CVE-2023-2454)\n\n* postgresql: row security policies disregard user ID changes after inlining. (CVE-2023-2455)\n\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.","solution":null,"affectedProducts":["Rocky Linux 8"],"fixes":[{"ticket":"2207568","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2207568","description":""},{"ticket":"2207569","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2207569","description":""}],"cves":[{"name":"CVE-2023-2454","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-2454","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"},{"name":"CVE-2023-2455","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-2455","cvss3ScoringVector":"UNKNOWN","cvss3BaseScore":"UNKNOWN","cwe":"UNKNOWN"}],"references":[],"publishedAt":"2023-08-28T18:40:52.742932Z","rpms":{"Rocky Linux 8":{"nvras":["postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.src.rpm","postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-contrib-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-contrib-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-contrib-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-contrib-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-debugsource-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-debugsource-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-docs-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-docs-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-docs-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-docs-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-plperl-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-plperl-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-plperl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-plperl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-plpython3-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-plpython3-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-plpython3-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-plpython3-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-pltcl-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-pltcl-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-pltcl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-pltcl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-server-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-server-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-server-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-server-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-server-devel-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-server-devel-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-server-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-server-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-static-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-static-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-test-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-test-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-test-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-test-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-test-rpm-macros-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-test-rpm-macros-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-upgrade-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-upgrade-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-upgrade-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-upgrade-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-upgrade-devel-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-upgrade-devel-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm","postgresql-upgrade-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm","postgresql-upgrade-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLSA-2023:4539 postgresql

August 28, 2023
An update is available for module.postgresql, postgresql. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for module.postgresql, postgresql. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


PostgreSQL is an advanced object-relational database management system (DBMS). Security Fix(es): * postgresql: schema_element defeats protective search_path changes (CVE-2023-2454) * postgresql: row security policies disregard user ID changes after inlining. (CVE-2023-2455) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.src.rpm

postgresql-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-contrib-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-contrib-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-contrib-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-contrib-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-debugsource-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-debugsource-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-docs-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-docs-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-docs-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-docs-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-plperl-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-plperl-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-plperl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-plperl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-plpython3-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-plpython3-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-plpython3-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-plpython3-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-pltcl-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-pltcl-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-pltcl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-pltcl-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-server-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-server-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-server-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-server-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-server-devel-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-server-devel-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-server-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-server-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-static-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-static-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-test-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-test-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-test-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-test-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-test-rpm-macros-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-test-rpm-macros-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-upgrade-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-upgrade-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-upgrade-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-upgrade-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-upgrade-devel-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-upgrade-devel-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

postgresql-upgrade-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.aarch64.rpm

postgresql-upgrade-devel-debuginfo-0:10.23-2.module+el8.8.0+1440+992378a9.x86_64.rpm

References

No References

CVEs

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-2454

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-2455

Severity
Name: RLSA-2023:4539
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=2207568

https://bugzilla.redhat.com/show_bug.cgi?id=2207569


Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo