{"type":"TYPE_SECURITY","shortCode":"RL","name":"RLSA-2023:4529","synopsis":"Moderate: libxml2 security update","severity":"SEVERITY_MODERATE","topic":"An update is available for libxml2.\nThis update affects Rocky Linux 8.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"The libxml2 library is a development toolbox providing the implementation of various XML standards.\n\nSecurity Fix(es):\n\n* libxml2: NULL dereference in xmlSchemaFixupComplexType (CVE-2023-28484)\n\n* libxml2: Hashing of empty dict strings isn't deterministic (CVE-2023-29469)\n\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.","solution":null,"affectedProducts":["Rocky Linux 8"],"fixes":[{"ticket":"2185984","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2185984","description":""},{"ticket":"2185994","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2185994","description":""}],"cves":[{"name":"CVE-2023-28484","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-28484","cvss3ScoringVector":"CVSS:3.1\/AV:N\/AC:H\/PR:N\/UI:N\/S:U\/C:N\/I:N\/A:H","cvss3BaseScore":"5.9","cwe":"CWE-20"},{"name":"CVE-2023-29469","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-29469","cvss3ScoringVector":"CVSS:3.1\/AV:N\/AC:H\/PR:N\/UI:N\/S:U\/C:N\/I:N\/A:H","cvss3BaseScore":"5.9","cwe":"CWE-20"}],"references":[],"publishedAt":"2023-10-06T23:10:01.903350Z","rpms":{"Rocky Linux 8":{"nvras":["libxml2-0:2.9.7-16.el8_8.1.aarch64.rpm","libxml2-0:2.9.7-16.el8_8.1.src.rpm","libxml2-debuginfo-0:2.9.7-16.el8_8.1.aarch64.rpm","libxml2-debugsource-0:2.9.7-16.el8_8.1.aarch64.rpm","libxml2-devel-0:2.9.7-16.el8_8.1.aarch64.rpm","python3-libxml2-0:2.9.7-16.el8_8.1.aarch64.rpm","python3-libxml2-debuginfo-0:2.9.7-16.el8_8.1.aarch64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLSA-2023:4529 libxml2 security update

October 6, 2023
An update is available for libxml2. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for libxml2. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


The libxml2 library is a development toolbox providing the implementation of various XML standards. Security Fix(es): * libxml2: NULL dereference in xmlSchemaFixupComplexType (CVE-2023-28484) * libxml2: Hashing of empty dict strings isn't deterministic (CVE-2023-29469) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

libxml2-0:2.9.7-16.el8_8.1.aarch64.rpm

libxml2-0:2.9.7-16.el8_8.1.src.rpm

libxml2-debuginfo-0:2.9.7-16.el8_8.1.aarch64.rpm

libxml2-debugsource-0:2.9.7-16.el8_8.1.aarch64.rpm

libxml2-devel-0:2.9.7-16.el8_8.1.aarch64.rpm

python3-libxml2-0:2.9.7-16.el8_8.1.aarch64.rpm

python3-libxml2-debuginfo-0:2.9.7-16.el8_8.1.aarch64.rpm

References

No References

CVEs

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-28484

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-29469

Severity
Name: RLSA-2023:4529
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=2185984

https://bugzilla.redhat.com/show_bug.cgi?id=2185994


Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo