openSUSE Security Update: Security update for connman
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2023:0370-1
Rating:             important
References:         #1210395 
Cross-References:   CVE-2023-28488
CVSS scores:
                    CVE-2023-28488 (NVD) : 6.5 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for connman fixes the following issues:

   - Update to 1.42

     * Fix issue with iwd and signal strength calculation.
     * Fix issue with iwd and handling service removal.
     * Fix issue with iwd and handling new connections.
     * Fix issue with handling default online check URL.
     * Fix issue with handling nameservers refresh.
     * Fix issue with handling proxy from DHCP lease. (boo#1210395
       CVE-2023-28488)
     * Fix issue with handling multiple proxies from PAC.
     * Fix issue with handling manual time update changes.
     * Fix issue with handling invalid gateway routes.
     * Fix issue with handling hidden WiFi agent requests.
     * Fix issue with handling WiFi SAE authentication failure.
     * Fix issue with handling DNS Proxy and TCP server replies.
     * Add support for regulatory domain following timezone.
     * Add support for localtime configuration option.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP4:

      zypper in -t patch openSUSE-2023-370=1



Package List:

   - openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64):

      connman-1.42-bp154.2.6.1
      connman-client-1.42-bp154.2.6.1
      connman-devel-1.42-bp154.2.6.1
      connman-doc-1.42-bp154.2.6.1
      connman-nmcompat-1.42-bp154.2.6.1
      connman-plugin-iospm-1.42-bp154.2.6.1
      connman-plugin-l2tp-1.42-bp154.2.6.1
      connman-plugin-openvpn-1.42-bp154.2.6.1
      connman-plugin-polkit-1.42-bp154.2.6.1
      connman-plugin-pptp-1.42-bp154.2.6.1
      connman-plugin-wireguard-1.42-bp154.2.6.1
      connman-test-1.42-bp154.2.6.1

   - openSUSE Backports SLE-15-SP4 (aarch64 ppc64le s390x x86_64):

      connman-plugin-vpnc-1.42-bp154.2.6.1

   - openSUSE Backports SLE-15-SP4 (aarch64 i586 s390x x86_64):

      connman-plugin-hh2serial-gps-1.42-bp154.2.6.1
      connman-plugin-tist-1.42-bp154.2.6.1


References:

   https://www.suse.com/security/cve/CVE-2023-28488.html
   https://bugzilla.suse.com/1210395

openSUSE: 2023:0370-1 important: connman

November 14, 2023
An update that fixes one vulnerability is now available

Description

This update for connman fixes the following issues: - Update to 1.42 * Fix issue with iwd and signal strength calculation. * Fix issue with iwd and handling service removal. * Fix issue with iwd and handling new connections. * Fix issue with handling default online check URL. * Fix issue with handling nameservers refresh. * Fix issue with handling proxy from DHCP lease. (boo#1210395 CVE-2023-28488) * Fix issue with handling multiple proxies from PAC. * Fix issue with handling manual time update changes. * Fix issue with handling invalid gateway routes. * Fix issue with handling hidden WiFi agent requests. * Fix issue with handling WiFi SAE authentication failure. * Fix issue with handling DNS Proxy and TCP server replies. * Add support for regulatory domain following timezone. * Add support for localtime configuration option.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP4: zypper in -t patch openSUSE-2023-370=1


Package List

- openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64): connman-1.42-bp154.2.6.1 connman-client-1.42-bp154.2.6.1 connman-devel-1.42-bp154.2.6.1 connman-doc-1.42-bp154.2.6.1 connman-nmcompat-1.42-bp154.2.6.1 connman-plugin-iospm-1.42-bp154.2.6.1 connman-plugin-l2tp-1.42-bp154.2.6.1 connman-plugin-openvpn-1.42-bp154.2.6.1 connman-plugin-polkit-1.42-bp154.2.6.1 connman-plugin-pptp-1.42-bp154.2.6.1 connman-plugin-wireguard-1.42-bp154.2.6.1 connman-test-1.42-bp154.2.6.1 - openSUSE Backports SLE-15-SP4 (aarch64 ppc64le s390x x86_64): connman-plugin-vpnc-1.42-bp154.2.6.1 - openSUSE Backports SLE-15-SP4 (aarch64 i586 s390x x86_64): connman-plugin-hh2serial-gps-1.42-bp154.2.6.1 connman-plugin-tist-1.42-bp154.2.6.1


References

https://www.suse.com/security/cve/CVE-2023-28488.html https://bugzilla.suse.com/1210395


Severity
Announcement ID: openSUSE-SU-2023:0370-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP4 .

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo