MGASA-2024-0013 - Updated hplip packages fix security vulnerabilities

Publication date: 16 Jan 2024
URL: https://advisories.mageia.org/MGASA-2024-0013.html
Type: security
Affected Mageia releases: 9

There were security issues in hplip's `hpps` program due to fixed /tmp
path usage in prnt/hpps/hppsfilter.c
This update fixes these issues.

References:
- https://bugs.mageia.org/show_bug.cgi?id=32701
- https://www.openwall.com/lists/oss-security/2023/11/17/1
- https://www.openwall.com/lists/oss-security/2024/01/04/1

SRPMS:
- 9/core/hplip-3.22.10-4.1.mga9

Mageia 2024-0013: hplip security update

There were security issues in hplip's `hpps` program due to fixed /tmp path usage in prnt/hpps/hppsfilter.c This update fixes these issues

Summary

There were security issues in hplip's `hpps` program due to fixed /tmp path usage in prnt/hpps/hppsfilter.c This update fixes these issues. References:

References

- https://bugs.mageia.org/show_bug.cgi?id=32701

- https://www.openwall.com/lists/oss-security/2023/11/17/1

- https://www.openwall.com/lists/oss-security/2024/01/04/1

Resolution

MGASA-2024-0013 - Updated hplip packages fix security vulnerabilities

SRPMS

- 9/core/hplip-3.22.10-4.1.mga9

Severity
Publication date: 16 Jan 2024
URL: https://advisories.mageia.org/MGASA-2024-0013.html
Type: security

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo