- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202312-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Leptonica: Multiple Vulnerabilities
     Date: December 18, 2023
     Bugs: #649752, #869416
       ID: 202312-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several vulnerabilities have been found in Leptonice, the worst of which
could lead to arbitrary code execution.

Background
==========

Leptonica is a C library for image processing and analysis.

Affected packages
=================

Package               Vulnerable    Unaffected
--------------------  ------------  ------------
media-libs/leptonica  < 1.81.0      >= 1.81.0

Description
===========

Multiple vulnerabilities have been discovered in Leptonica. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Leptonica users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/leptonica-1.81.0"

References
==========

[ 1 ] CVE-2017-18196
      https://nvd.nist.gov/vuln/detail/CVE-2017-18196
[ 2 ] CVE-2018-7186
      https://nvd.nist.gov/vuln/detail/CVE-2018-7186
[ 3 ] CVE-2018-7247
      https://nvd.nist.gov/vuln/detail/CVE-2018-7247
[ 4 ] CVE-2018-7440
      https://nvd.nist.gov/vuln/detail/CVE-2018-7440
[ 5 ] CVE-2018-7441
      https://nvd.nist.gov/vuln/detail/CVE-2018-7441
[ 6 ] CVE-2018-7442
      https://nvd.nist.gov/vuln/detail/CVE-2018-7442
[ 7 ] CVE-2022-38266
      https://nvd.nist.gov/vuln/detail/CVE-2022-38266

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202312-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202312-01: Leptonica: Multiple Vulnerabilities

Several vulnerabilities have been found in Leptonice, the worst of which could lead to arbitrary code execution.

Summary

Multiple vulnerabilities have been discovered in Leptonica. Please review the CVE identifiers referenced below for details.

Resolution

All Leptonica users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/leptonica-1.81.0"

References

[ 1 ] CVE-2017-18196 https://nvd.nist.gov/vuln/detail/CVE-2017-18196 [ 2 ] CVE-2018-7186 https://nvd.nist.gov/vuln/detail/CVE-2018-7186 [ 3 ] CVE-2018-7247 https://nvd.nist.gov/vuln/detail/CVE-2018-7247 [ 4 ] CVE-2018-7440 https://nvd.nist.gov/vuln/detail/CVE-2018-7440 [ 5 ] CVE-2018-7441 https://nvd.nist.gov/vuln/detail/CVE-2018-7441 [ 6 ] CVE-2018-7442 https://nvd.nist.gov/vuln/detail/CVE-2018-7442 [ 7 ] CVE-2022-38266 https://nvd.nist.gov/vuln/detail/CVE-2022-38266

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202312-01

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: Leptonica: Multiple Vulnerabilities
Date: December 18, 2023
Bugs: #649752, #869416
ID: 202312-01

Synopsis

Several vulnerabilities have been found in Leptonice, the worst of which could lead to arbitrary code execution.

Background

Leptonica is a C library for image processing and analysis.

Affected Packages

Package Vulnerable Unaffected -------------------- ------------ ------------ media-libs/leptonica < 1.81.0 >= 1.81.0

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo