-------------------------------------------------------------------------
Debian LTS Advisory DLA-3723-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                       Guilhem Moulin
January 27, 2024                              https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : libspreadsheet-parsexlsx-perl
Version        : 0.27-2+deb10u1
CVE ID         : CVE-2024-22368 CVE-2024-23525
Debian Bug     : 1061098

Security vulnerabilities were found in libspreadsheet-parsexlsx-perl, a
Perl module to parse XLSX files, which could lead to denial of service
or server-side request forgery via crafted input.

CVE-2024-22368

    Le Dinh Hai discovered that the memoize implementation allows
    attacker to allocate an arbitrary memory size, which could lead to
    denial of service via memory exhaustion.

CVE-2024-23525

    An Pham discovered an XML external entity (XXE) vulnerability via
    crafted input, which could lead to denial of service or server-side
    request forgery.

For Debian 10 buster, these problems have been fixed in version
0.27-2+deb10u1.

We recommend that you upgrade your libspreadsheet-parsexlsx-perl packages.

For the detailed security status of libspreadsheet-parsexlsx-perl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libspreadsheet-parsexlsx-perl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3723-1: libspreadsheet-parsexlsx-perl security update

January 27, 2024
Security vulnerabilities were found in libspreadsheet-parsexlsx-perl, a Perl module to parse XLSX files, which could lead to denial of service or server-side request forgery via cr...

Summary

CVE-2024-22368

Le Dinh Hai discovered that the memoize implementation allows
attacker to allocate an arbitrary memory size, which could lead to
denial of service via memory exhaustion.

CVE-2024-23525

An Pham discovered an XML external entity (XXE) vulnerability via
crafted input, which could lead to denial of service or server-side
request forgery.

For Debian 10 buster, these problems have been fixed in version
0.27-2+deb10u1.

We recommend that you upgrade your libspreadsheet-parsexlsx-perl packages.

For the detailed security status of libspreadsheet-parsexlsx-perl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libspreadsheet-parsexlsx-perl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : libspreadsheet-parsexlsx-perl
Version : 0.27-2+deb10u1
CVE ID : CVE-2024-22368 CVE-2024-23525
Debian Bug : 1061098

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo