- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3609-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                    Bastien Roucaries
October 08, 2023                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : prometheus-alertmanager
Version        : 0.15.3+ds-3+deb10u1
CVE ID         : CVE-2023-40577
Debian Bug     : 1050558

prometheus-alertmanager package, a component of Prometheus,
an application used for event monitoring and alerting,
was vulnerable to stored XSS type attack.

Alertmanager handles alerts sent by client applications such as the
Prometheus server. An attacker with the permission to perform POST
requests on the /api/v1/alerts endpoint could be able to execute
arbitrary JavaScript code on the users of Prometheus Alertmanager.

For Debian 10 buster, this problem has been fixed in version
0.15.3+ds-3+deb10u1.

We recommend that you upgrade your prometheus-alertmanager packages.

For the detailed security status of prometheus-alertmanager please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/prometheus-alertmanager

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3609-1: prometheus-alertmanager security update

October 8, 2023
prometheus-alertmanager package, a component of Prometheus, an application used for event monitoring and alerting, was vulnerable to stored XSS type attack

Summary

Alertmanager handles alerts sent by client applications such as the
Prometheus server. An attacker with the permission to perform POST
requests on the /api/v1/alerts endpoint could be able to execute
arbitrary JavaScript code on the users of Prometheus Alertmanager.

For Debian 10 buster, this problem has been fixed in version
0.15.3+ds-3+deb10u1.

We recommend that you upgrade your prometheus-alertmanager packages.

For the detailed security status of prometheus-alertmanager please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/prometheus-alertmanager

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : prometheus-alertmanager
Version : 0.15.3+ds-3+deb10u1
CVE ID : CVE-2023-40577
Debian Bug : 1050558

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo