Red Hat: 2014:1042-01: java-1.7.1-ibm: Critical Advisory
Posted by Benjamin D. Thomas   
RedHat Linux Updated java-1.7.1-ibm packages that fix several security issues are now available for Red Hat Enterprise Linux 7 Supplementary. Red Hat Product Security has rated this update as having Critical security [More...]
=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: java-1.7.1-ibm security update
Advisory ID:       RHSA-2014:1042-01
Product:           Red Hat Enterprise Linux Supplementary
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2014-1042.html
Issue date:        2014-08-11
CVE Names:         CVE-2014-4208 CVE-2014-4209 CVE-2014-4218 
                   CVE-2014-4219 CVE-2014-4220 CVE-2014-4221 
                   CVE-2014-4227 CVE-2014-4244 CVE-2014-4252 
                   CVE-2014-4262 CVE-2014-4263 CVE-2014-4265 
                   CVE-2014-4266 
=====================================================================

1. Summary:

Updated java-1.7.1-ibm packages that fix several security issues are now
available for Red Hat Enterprise Linux 7 Supplementary.

Red Hat Product Security has rated this update as having Critical security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client Supplementary (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode Supplementary (v. 7) - x86_64
Red Hat Enterprise Linux Server Supplementary (v. 7) - ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 7) - x86_64

3. Description:

IBM Java SE version 7 Release 1 includes the IBM Java Runtime Environment
and the IBM Java Software Development Kit.

This update fixes several vulnerabilities in the IBM Java Runtime
Environment and the IBM Java Software Development Kit. Detailed
vulnerability descriptions are linked from the IBM Security alerts
page, listed in the References section. (CVE-2014-4208, CVE-2014-4209,
CVE-2014-4218, CVE-2014-4219, CVE-2014-4220, CVE-2014-4221, CVE-2014-4227,
CVE-2014-4244, CVE-2014-4252, CVE-2014-4262, CVE-2014-4263, CVE-2014-4265,
CVE-2014-4266)

The CVE-2014-4262 issue was discovered by Florian Weimer of Red Hat
Product Security.

All users of java-1.7.1-ibm are advised to upgrade to these updated
packages, containing the IBM Java SE 7R1 SR1-FP1 release. All running
instances of IBM Java must be restarted for the update to take effect.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1075795 - CVE-2014-4262 OpenJDK: AtomicReferenceFieldUpdater missing primitive type check (Libraries, 8039520)
1119475 - CVE-2014-4244 OpenJDK: RSA blinding issues (Security, 8031346)
1119476 - CVE-2014-4263 OpenJDK: insufficient Diffie-Hellman public key validation (Security, 8037162)
1119483 - CVE-2014-4221 OpenJDK: MethodHandles.Lookup insufficient modifiers checks (Libraries, 8035788)
1119596 - CVE-2014-4219 OpenJDK: Bytecode verification does not prevent ctor calls to this() and super() (Hotspot, 8035119)
1119608 - CVE-2014-4209 OpenJDK: SubjectDelegator protection insufficient (JMX, 8029755)
1119611 - CVE-2014-4218 OpenJDK: Clone interfaces passed to proxy methods (Libraries, 8035009)
1119613 - CVE-2014-4252 OpenJDK: Prevent instantiation of service with non-public constructor (Security, 8035004)
1119615 - CVE-2014-4266 OpenJDK: InfoBuilder incorrect return values (Serviceability, 8033301)
1119912 - CVE-2014-4227 Oracle JDK: unspecified vulnerability fixed in 6u81, 7u65 and 8u11 (Deployment)
1119913 - CVE-2014-4265 Oracle JDK: unspecified vulnerability fixed in 6u81, 7u65 and 8u11 (Deployment)
1119914 - CVE-2014-4220 Oracle JDK: unspecified vulnerability fixed in 7u65 and 8u11 (Deployment)
1119915 - CVE-2014-4208 Oracle JDK: unspecified vulnerability fixed in 7u65 and 8u11 (Deployment)

6. Package List:

Red Hat Enterprise Linux Client Supplementary (v. 7):

x86_64:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-jdbc-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-plugin-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Supplementary (v. 7):

x86_64:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 7):

ppc64:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.ppc.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.ppc64.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.ppc64.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.ppc.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.ppc64.rpm
java-1.7.1-ibm-jdbc-1.7.1.1.1-1jpp.1.el7_0.ppc64.rpm
java-1.7.1-ibm-plugin-1.7.1.1.1-1jpp.1.el7_0.ppc.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.ppc64.rpm

s390x:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.s390.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.s390x.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.s390x.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.s390.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.s390x.rpm
java-1.7.1-ibm-jdbc-1.7.1.1.1-1jpp.1.el7_0.s390x.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.s390x.rpm

x86_64:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-jdbc-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-plugin-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 7):

x86_64:
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-demo-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.i686.rpm
java-1.7.1-ibm-devel-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-jdbc-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-plugin-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm
java-1.7.1-ibm-src-1.7.1.1.1-1jpp.1.el7_0.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2014-4208.html
https://www.redhat.com/security/data/cve/CVE-2014-4209.html
https://www.redhat.com/security/data/cve/CVE-2014-4218.html
https://www.redhat.com/security/data/cve/CVE-2014-4219.html
https://www.redhat.com/security/data/cve/CVE-2014-4220.html
https://www.redhat.com/security/data/cve/CVE-2014-4221.html
https://www.redhat.com/security/data/cve/CVE-2014-4227.html
https://www.redhat.com/security/data/cve/CVE-2014-4244.html
https://www.redhat.com/security/data/cve/CVE-2014-4252.html
https://www.redhat.com/security/data/cve/CVE-2014-4262.html
https://www.redhat.com/security/data/cve/CVE-2014-4263.html
https://www.redhat.com/security/data/cve/CVE-2014-4265.html
https://www.redhat.com/security/data/cve/CVE-2014-4266.html
https://access.redhat.com/security/updates/classification/#critical
https://www.ibm.com/developerworks/java/jdk/alerts/

8. Contact:

The Red Hat security contact is .  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2014 Red Hat, Inc.