Gentoo: 201406-34 KDE Libraries: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been discovered in KDE Libraries, the worst of which could lead to man-in-the-middle attacks.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201406-34
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: KDE Libraries: Multiple vulnerabilities
     Date: June 29, 2014
     Bugs: #358025, #384227, #469140, #513726
       ID: 201406-34

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in KDE Libraries, the
worst of which could lead to man-in-the-middle attacks.

Background
==========

KDE is a feature-rich graphical desktop environment for Linux and
Unix-like operating systems. KDE Libraries contains libraries needed by
all KDE applications.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  kde-base/kdelibs           < 4.12.5-r1              >= 4.12.5-r1 

Description
===========

Multiple vulnerabilities have been discovered in KDE Libraries. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause a man-in-the-middle attack via any 
certificate issued by a legitimate certification authority.
Furthermore, a local attacker may gain knowledge of user passwords
through an information leak.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All KDE users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-4.12.5-r1"

References
==========

[ 1 ] CVE-2011-1094
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1094
[ 2 ] CVE-2011-3365
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3365
[ 3 ] CVE-2013-2074
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2074
[ 4 ] CVE-2014-3494
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3494

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201406-34.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5