Gentoo: 201406-33 Wireshark: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in Wireshark, the worst of which allows remote attackers to execute arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201406-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Wireshark: Multiple vulnerabilities
     Date: June 29, 2014
     Bugs: #503792, #507298, #508506, #513094
       ID: 201406-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Wireshark, the worst of
which allows remote attackers to execute arbitrary code.

Background
==========

Wireshark is a network protocol analyzer formerly known as ethereal.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-analyzer/wireshark       < 1.10.8                 *>= 1.8.15 
                                                            >= 1.10.8 

Description
===========

Multiple vulnerabilities have been discovered in Wireshark. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker can cause arbitrary code execution or a Denial of
Service condition via a specially crafted packet.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Wireshark 1.8.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.15"

All Wireshark 1.10.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.8"

References
==========

[ 1 ] CVE-2014-2281
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2281
[ 2 ] CVE-2014-2282
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2282
[ 3 ] CVE-2014-2283
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2283
[ 4 ] CVE-2014-2299
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2299
[ 5 ] CVE-2014-2907
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2907
[ 6 ] CVE-2014-4020
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-4020
[ 7 ] CVE-2014-4174
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-4174

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201406-33.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5