Gentoo: 201405-01 udisks: Arbitrary code execution
Posted by Benjamin D. Thomas   
Gentoo A stack-based buffer overflow vulnerability has been found in udisks, allowing a local attacker to possibly execute arbitrary code or cause Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201405-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: udisks: Arbitrary code execution
     Date: May 02, 2014
     Bugs: #504100
       ID: 201405-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A stack-based buffer overflow vulnerability has been found in udisks,
allowing a local attacker to possibly execute arbitrary code or cause
Denial of Service.

Background
==========

udisks is an abstraction for enumerating block devices and performing
operations on them.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-fs/udisks                < 2.1.3                   *>= 1.0.5 
                                                             >= 2.1.3 

Description
===========

A stack-based buffer overflow can be triggered when udisks is given a
long path name as a mount point.

Impact
======

A local attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All udisks 1.0 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-fs/udisks-1.0.5:0"

All udisks 2.0 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-fs/udisks-2.1.3"

References
==========

[ 1 ] CVE-2014-0004
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0004

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201405-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5