Red Hat: 2014:0455-01: openstack-glance: Important Advisory
Posted by Benjamin D. Thomas   
RedHat Linux Updated openstack-glance packages that fix one security issue are now available for Red Hat Enterprise Linux OpenStack Platform 4.0. The Red Hat Security Response Team has rated this update as having [More...]
=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: openstack-glance security update
Advisory ID:       RHSA-2014:0455-01
Product:           Red Hat Enterprise Linux OpenStack Platform
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2014-0455.html
Issue date:        2014-04-30
CVE Names:         CVE-2014-0162 
=====================================================================

1. Summary:

Updated openstack-glance packages that fix one security issue are now
available for Red Hat Enterprise Linux OpenStack Platform 4.0.

The Red Hat Security Response Team has rated this update as having
Important security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from the
CVE link in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux OpenStack Platform 4.0 - noarch

3. Description:

OpenStack Image service (glance) provides discovery, registration, and
delivery services for disk and server images. It provides the ability to
copy or snapshot a server image, and immediately store it away.
Stored images can be used as a template to get new servers up and running
quickly and more consistently than installing a server operating system and
individually configuring additional services.

It was found that Sheepdog, a distributed object storage system, did not
properly validate Sheepdog image URIs. A remote attacker able to insert or
modify glance image metadata could use this flaw to execute arbitrary
commands with the privileges of the user running the glance service.
Note that only OpenStack Image setups using the Sheepdog back end were
affected. (CVE-2014-0162)

Red Hat would like to thank the OpenStack project for reporting this issue.
Upstream acknowledges Paul McMillan (Nebula) as the original reporter.

All users of openstack-glance are advised to upgrade to these updated
packages, which correct this issue. After installing the updated packages,
the running glance services will be restarted automatically.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/site/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1085163 - CVE-2014-0162 openstack-glance: remote code execution in Glance Sheepdog backend

6. Package List:

Red Hat Enterprise Linux OpenStack Platform 4.0:

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/RHOS/SRPMS/openstack-glance-2013.2.2-3.el6ost.src.rpm

noarch:
openstack-glance-2013.2.2-3.el6ost.noarch.rpm
openstack-glance-doc-2013.2.2-3.el6ost.noarch.rpm
python-glance-2013.2.2-3.el6ost.noarch.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2014-0162.html
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is .  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2014 Red Hat, Inc.