Ubuntu: 2160-1: LibYAML vulnerability
Posted by Benjamin D. Thomas   
Ubuntu LibYAML could be made to crash or run programs if it opened a speciallycrafted YAML document.
==========================================================================
Ubuntu Security Notice USN-2160-1
April 03, 2014

libyaml vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 13.10
- Ubuntu 12.10
- Ubuntu 12.04 LTS

Summary:

LibYAML could be made to crash or run programs if it opened a specially
crafted YAML document.

Software Description:
- libyaml: Fast YAML 1.1 parser and emitter library

Details:

Ivan Fratric discovered that LibYAML incorrectly handled certain malformed
YAML documents. An attacker could use this issue to cause LibYAML to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 13.10:
  libyaml-0-2                     0.1.4-2ubuntu0.13.10.3

Ubuntu 12.10:
  libyaml-0-2                     0.1.4-2ubuntu0.12.10.3

Ubuntu 12.04 LTS:
  libyaml-0-2                     0.1.4-2ubuntu0.12.04.3

After a standard system update you need to restart applications using
LibYAML to make all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-2160-1
  CVE-2014-2525

Package Information:
  https://launchpad.net/ubuntu/+source/libyaml/0.1.4-2ubuntu0.13.10.3
  https://launchpad.net/ubuntu/+source/libyaml/0.1.4-2ubuntu0.12.10.3
  https://launchpad.net/ubuntu/+source/libyaml/0.1.4-2ubuntu0.12.04.3