Ubuntu: 2155-1: OpenSSH vulnerability
Posted by Benjamin D. Thomas   
Ubuntu OpenSSH incorrectly handled environment restrictions with wildcards.
==========================================================================
Ubuntu Security Notice USN-2155-1
March 25, 2014

openssh vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 13.10
- Ubuntu 12.10
- Ubuntu 12.04 LTS
- Ubuntu 10.04 LTS

Summary:

OpenSSH incorrectly handled environment restrictions with wildcards.

Software Description:
- openssh: secure shell (SSH) for secure access to remote machines

Details:

Jann Horn discovered that OpenSSH incorrectly handled wildcards in
AcceptEnv lines. A remote attacker could use this issue to possibly bypass
certain intended environment variable restrictions.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 13.10:
  openssh-server                  1:6.2p2-6ubuntu0.2

Ubuntu 12.10:
  openssh-server                  1:6.0p1-3ubuntu1.1

Ubuntu 12.04 LTS:
  openssh-server                  1:5.9p1-5ubuntu1.2

Ubuntu 10.04 LTS:
  openssh-server                  1:5.3p1-3ubuntu7.1

In general, a standard system update will make all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-2155-1
  CVE-2014-2532

Package Information:
  https://launchpad.net/ubuntu/+source/openssh/1:6.2p2-6ubuntu0.2
  https://launchpad.net/ubuntu/+source/openssh/1:6.0p1-3ubuntu1.1
  https://launchpad.net/ubuntu/+source/openssh/1:5.9p1-5ubuntu1.2
  https://launchpad.net/ubuntu/+source/openssh/1:5.3p1-3ubuntu7.1