Slackware: 2014-050-01: gnutls: Security Update
Posted by Benjamin D. Thomas   
Slackware New gnutls packages are available for Slackware 14.0, 14.1, and -current to fix a security issue. [More Info...]
[slackware-security]  gnutls (SSA:2014-050-01)

New gnutls packages are available for Slackware 14.0, 14.1, and -current to
fix a security issue.


Here are the details from the Slackware 14.1 ChangeLog:
+--------------------------+
patches/packages/gnutls-3.1.21-i486-1_slack14.1.txz:  Upgraded.
  This update fixes a flaw where a version 1 intermediate certificate would be
  considered as a CA certificate by GnuTLS by default.
  For more information, see:
    http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1959
  (* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating FTP and rsync hosting
to the Slackware project!  :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware-14.0/patches/packages/gnutls-3.0.31-i486-2_slack14.0.txz

Updated package for Slackware x86_64 14.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.0/patches/packages/gnutls-3.0.31-x86_64-2_slack14.0.txz

Updated package for Slackware 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware-14.1/patches/packages/gnutls-3.1.21-i486-1_slack14.1.txz

Updated package for Slackware x86_64 14.1:
ftp://ftp.slackware.com/pub/slackware/slackware64-14.1/patches/packages/gnutls-3.1.21-x86_64-1_slack14.1.txz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/gnutls-3.1.21-i486-1.txz

Updated package for Slackware x86_64 -current:
ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/gnutls-3.1.21-x86_64-1.txz


MD5 signatures:
+-------------+

Slackware 14.0 package:
55f0ee50fd62526c802dca234d1cde2f  gnutls-3.0.31-i486-2_slack14.0.txz

Slackware x86_64 14.0 package:
f81fbcd3dc0ddb04e0c49e4d75786d43  gnutls-3.0.31-x86_64-2_slack14.0.txz

Slackware 14.1 package:
e03018b41bf4b52ea0f0ddc7edf3af09  gnutls-3.1.21-i486-1_slack14.1.txz

Slackware x86_64 14.1 package:
a833400870b52a12561d197f4fade248  gnutls-3.1.21-x86_64-1_slack14.1.txz

Slackware -current package:
4d546890fb2ee44ea103d551e418a495  n/gnutls-3.1.21-i486-1.txz

Slackware x86_64 -current package:
5b2087af6bc05d86ddaa3b45a03e2971  n/gnutls-3.1.21-x86_64-1.txz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg gnutls-3.1.21-i486-1_slack14.1.txz


+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key
security@slackware.com