Gentoo: 201401-11 Perl, Locale Maketext Perl module: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in Perl and Locale::Maketext Perl module, the worst of which could allow a context-dependent attacker to execute arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201401-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Perl, Locale Maketext Perl module: Multiple vulnerabilities
     Date: January 19, 2014
     Bugs: #384887, #448632, #460444, #483448
       ID: 201401-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Perl and Locale::Maketext
Perl module, the worst of which could allow a context-dependent
attacker to execute arbitrary code.

Background
==========

Perl is Larry Wall's Practical Extraction and Report Language.
Locale::Maketext is a Perl module - framework for localization.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/perl                < 5.16.3                  >= 5.16.3
  2  perl-core/locale-maketext
                                 < 1.230.0                 >= 1.230.0
    -------------------------------------------------------------------
     2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in Perl and
Locale::Maketext Perl module. Please review the CVE identifiers
referenced below for details.

Impact
======

A context-dependent attacker could possibly execute arbitrary code with
the privileges of the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Perl users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/perl-5.16.3"

All Locale::Maketext users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=perl-core/locale-maketext-1.230.0"

References
==========

[ 1 ] CVE-2011-2728
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2728
[ 2 ] CVE-2011-2939
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2939
[ 3 ] CVE-2012-5195
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-5195
[ 4 ] CVE-2013-1667
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1667

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201401-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5