Gentoo: 201401-06 Git: Privilege escalation
Posted by Benjamin D. Thomas   
Gentoo A stack-based buffer overflow in Git might allow a local attacker to gain escalated privileges.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201401-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Git: Privilege escalation
     Date: January 10, 2014
     Bugs: #335891
       ID: 201401-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A stack-based buffer overflow in Git might allow a local attacker to
gain escalated privileges.

Background
==========

Git is a free and open source distributed version control system
designed to handle everything from small to very large projects with
speed and efficiency.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-vcs/git                 < 1.7.2.2                 >= 1.7.2.2

Description
===========

Git contains a stack-based buffer overflow in the is_git_directory
function in setup.c.

Impact
======

A local attacker could gain escalated privileges via a specially
crafted git repository.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Git users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/git-1.7.2.2"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 11, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-2542
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2542

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201401-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5