Gentoo: 201311-08 Netpbm: User-assisted arbitrary code execution
Posted by Benjamin D. Thomas   
Gentoo A vulnerability in Netpbm could result in execution of arbitrary code or Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201311-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Netpbm: User-assisted arbitrary code execution
     Date: November 13, 2013
     Bugs: #308025
       ID: 201311-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Netpbm could result in execution of arbitrary code
or Denial of Service.

Background
==========

Netpbm is a toolkit for manipulation of graphic images, including
conversion of images between a variety of different formats.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-libs/netpbm           < 10.49.00               >= 10.49.00

Description
===========

A stack-based buffer overflow exists in converter/ppm/xpmtoppm.c in
Netpbm.

Impact
======

A remote attacker could entice a user to open a specially crafted XMP
file using Netpbm, possibly resulting in  execution of arbitrary code
with the privileges of the process, or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Netpbm users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/netpbm-10.49.00"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2009-4274
      http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-4274

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201311-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5