Gentoo: 201310-15 GNU Automake: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in GNU Automake, allowing local arbitrary command execution with the privileges of the user running an Automake-based build.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201310-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: GNU Automake: Multiple vulnerabilities
     Date: October 25, 2013
     Bugs: #295357, #426336
       ID: 201310-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GNU Automake, allowing
local arbitrary command execution with the privileges of the user
running an Automake-based build.

Background
==========

GNU Automake is a tool for automatically generating Makefile.in files
compliant with the GNU Coding Standards.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-devel/automake           < 1.11.6                  >= 1.11.6

Description
===========

Multiple vulnerabilities have been discovered in GNU Automake. Please
review the CVE identifiers referenced below for details.

Impact
======

A local attacker could execute arbitrary commands with the privileges
of the user running an Automake-based build.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Automake users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-devel/automake-1.11.6"

References
==========

[ 1 ] CVE-2009-4029
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-4029
[ 2 ] CVE-2012-3386
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3386

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201310-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5