Gentoo: 201309-09 LibRaw, libkdcraw: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in LibRaw and libkdcraw, the worst of which may lead to arbitrary code execution.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201309-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: LibRaw, libkdcraw: Multiple vulnerabilities
     Date: September 15, 2013
     Bugs: #471694, #482926
       ID: 201309-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in LibRaw and libkdcraw, the
worst of which may lead to arbitrary code execution.

Background
==========

LibRaw is a library for reading RAW files obtained from digital photo
cameras. libkdcraw is a wrapper for LibRaw within KDE.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-libs/libraw            < 0.15.4                  >= 0.15.4
  2  kde-base/libkdcraw         < 4.10.5-r1              >= 4.10.5-r1
    -------------------------------------------------------------------
     2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in LibRaw and libkdcraw.
Please review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to open a specially crafted file,
possibly resulting in arbitrary code execution or Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All LibRaw users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libraw-0.15.4"

All libkdcraw users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=kde-base/libkdcraw-4.10.5-r1"

References
==========

[ 1 ] CVE-2013-1438
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1438
[ 2 ] CVE-2013-1439
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1439
[ 3 ] CVE-2013-2126
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2126
[ 4 ] CVE-2013-2127
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2127

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201309-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5