Mandriva: 2013:141: libxslt
Posted by Benjamin D. Thomas   
Mandrake Updated libxslt packages fix security vulnerability: Nicholas Gregoire discovered that libxslt incorrectly handled certain empty values. If a user or automated system were tricked into processing a specially crafted XSLT document, a remote attacker could [More...]
 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:141
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : libxslt
 Date    : April 11, 2013
 Affected: Business Server 1.0, Enterprise Server 5.0
 _______________________________________________________________________

 Problem Description:

 Updated libxslt packages fix security vulnerability:
 
 Nicholas Gregoire discovered that libxslt incorrectly handled
 certain empty values. If a user or automated system were tricked into
 processing a specially crafted XSLT document, a remote attacker could
 cause libxslt to crash, causing a denial of service (CVE-2012-6139).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-6139
 https://bugzilla.gnome.org/show_bug.cgi?id=685328
 https://wiki.mageia.org/en/Support/Advisories/MGASA-2013-0107
 _______________________________________________________________________

 Updated Packages:

 Mandriva Enterprise Server 5:
 d9cc0579da4d136a0d062c1078fd108f  mes5/i586/libxslt1-1.1.24-3.4mdvmes5.2.i586.rpm
 c9b06cef7d5a2668b413cd8c53e3613a  mes5/i586/libxslt-devel-1.1.24-3.4mdvmes5.2.i586.rpm
 cdc0b9e7670d208f8d3d7735824860a9  mes5/i586/libxslt-proc-1.1.24-3.4mdvmes5.2.i586.rpm
 30c4cab94e5d3e489ba71803824dfd69  mes5/i586/python-libxslt-1.1.24-3.4mdvmes5.2.i586.rpm 
 03c95e446be2399ee67962c751d2c279  mes5/SRPMS/libxslt-1.1.24-3.4mdvmes5.2.src.rpm

 Mandriva Enterprise Server 5/X86_64:
 a0c13f507bcb015a466257020a2d8adc  mes5/x86_64/lib64xslt1-1.1.24-3.4mdvmes5.2.x86_64.rpm
 6619487f220f49565eb1e6960c5655aa  mes5/x86_64/lib64xslt-devel-1.1.24-3.4mdvmes5.2.x86_64.rpm
 dd106118af9c87fb11e71b4ae463e647  mes5/x86_64/libxslt-proc-1.1.24-3.4mdvmes5.2.x86_64.rpm
 edced14e8d64ce6dffdc7b1650a6e5b3  mes5/x86_64/python-libxslt-1.1.24-3.4mdvmes5.2.x86_64.rpm 
 03c95e446be2399ee67962c751d2c279  mes5/SRPMS/libxslt-1.1.24-3.4mdvmes5.2.src.rpm

 Mandriva Business Server 1/X86_64:
 d16729cbfcb9dca701a747c4dc33d48f  mbs1/x86_64/lib64xslt1-1.1.26-6.20120127.3.mbs1.x86_64.rpm
 01ce0c23bcccb4137dbba5e6d241fb55  mbs1/x86_64/lib64xslt-devel-1.1.26-6.20120127.3.mbs1.x86_64.rpm
 39f221d58e2a2f5e441a9b434dac572f  mbs1/x86_64/python-libxslt-1.1.26-6.20120127.3.mbs1.x86_64.rpm
 ad0ebe3fd3ebaec58ae909909b18439e  mbs1/x86_64/xsltproc-1.1.26-6.20120127.3.mbs1.x86_64.rpm 
 6c7d4bef7fe3da682edb2395b8e15850  mbs1/SRPMS/libxslt-1.1.26-6.20120127.3.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________