Mandriva: 2013:126: snack
Posted by Benjamin D. Thomas   
Mandrake Updated snack packages fix security vulnerability: Two vulnerabilities have been discovered in Snack Sound Toolkit, which are caused due to missing boundary checks in the GetWavHeader() function (generic/jkSoundFile.c) when parsing either format sub-chunks [More...]
 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:126
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : snack
 Date    : April 10, 2013
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 Updated snack packages fix security vulnerability:
 
 Two vulnerabilities have been discovered in Snack Sound Toolkit,
 which are caused due to missing boundary checks in the GetWavHeader()
 function (generic/jkSoundFile.c) when parsing either format sub-chunks
 or unknown sub-chunks. This can be exploited to cause a heap-based
 buffer overflow via specially crafted WAV files with overly large
 chunk sizes specified (CVE-2012-6303).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-6303
 https://wiki.mageia.org/en/Support/Advisories/MGASA-2013-0017
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 cc5a34a07194a2d4f226de5b7f336c8c  mbs1/x86_64/python-snack-2.2.10-11.1.mbs1.x86_64.rpm
 6c10508707c1370f2ba84756c912e83b  mbs1/x86_64/tcl-snack-2.2.10-11.1.mbs1.x86_64.rpm 
 834f2117e1251aa60d1aa7d8f95b2cec  mbs1/SRPMS/snack-2.2.10-11.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________