Mandriva: 2013:100: lighttpd
Posted by Benjamin D. Thomas   
Mandrake The http_request_split_value function in request.c in lighttpd before 1.4.32 allows remote attackers to cause a denial of service (infinite loop) via a request with a header containing an empty token, as demonstrated using the Connection: TE,,Keep-Alive header (CVE-2012-5533). [More...]
 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:100
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : lighttpd
 Date    : April 10, 2013
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 The http_request_split_value function in request.c in lighttpd
 before 1.4.32 allows remote attackers to cause a denial of service
 (infinite loop) via a request with a header containing an empty
 token, as demonstrated using the Connection: TE,,Keep-Alive header
 (CVE-2012-5533).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5533
 https://wiki.mageia.org/en/Support/Advisories/MGASA-2012-0345
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 1f9672e603a521ef9700c93988e78d8a  mbs1/x86_64/lighttpd-1.4.30-6.1.mbs1.x86_64.rpm
 0bf593384f0eae5b5da53534eb4a2dc4  mbs1/x86_64/lighttpd-mod_auth-1.4.30-6.1.mbs1.x86_64.rpm
 027debf6342d1f45a9757ac1a442937d  mbs1/x86_64/lighttpd-mod_cml-1.4.30-6.1.mbs1.x86_64.rpm
 a1364305e91d876cb8a053ed82a8e965  mbs1/x86_64/lighttpd-mod_compress-1.4.30-6.1.mbs1.x86_64.rpm
 d015e5c8d57800b306cd4ad5cde9b3f5  mbs1/x86_64/lighttpd-mod_magnet-1.4.30-6.1.mbs1.x86_64.rpm
 d1b1796113f1e852ddc36694ee8b5e76  mbs1/x86_64/lighttpd-mod_mysql_vhost-1.4.30-6.1.mbs1.x86_64.rpm
 76399d4981fb67e66de73040afccd47f  mbs1/x86_64/lighttpd-mod_trigger_b4_dl-1.4.30-6.1.mbs1.x86_64.rpm
 993e7c600ff357af50bbb7a94ee8bc5a  mbs1/x86_64/lighttpd-mod_webdav-1.4.30-6.1.mbs1.x86_64.rpm 
 83adc393b5d45412afe0b1bcf6de78ef  mbs1/SRPMS/lighttpd-1.4.30-6.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________