Mandriva: 2013:069: cups-pk-helper
Posted by Benjamin D. Thomas   
Mandrake Updated cups-pk-helper package fixes security vulnerability: cups-pk-helper, a PolicyKit helper to configure CUPS with fine-grained privileges, wraps CUPS function calls in an insecure way. This could lead to uploading sensitive data to a CUPS resource, or overwriting [More...]
 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:069
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : cups-pk-helper
 Date    : April 8, 2013
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 Updated cups-pk-helper package fixes security vulnerability:
 
 cups-pk-helper, a PolicyKit helper to configure CUPS with fine-grained
 privileges, wraps CUPS function calls in an insecure way. This could
 lead to uploading sensitive data to a CUPS resource, or overwriting
 specific files with the content of a CUPS resource. The user would
 have to explicitly approve the action (CVE-2012-4510).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4510
 https://wiki.mageia.org/en/Support/Advisories/MGASA-2012-0310
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 6c7fbb5f4dcbf028951e62ffabfe5a9f  mbs1/x86_64/cups-pk-helper-0.2.1-2.1.mbs1.x86_64.rpm 
 657c1b8aacdba57bc05236215ccb37a0  mbs1/SRPMS/cups-pk-helper-0.2.1-2.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________