Mandriva: 2013:018: automake
Posted by Benjamin D. Thomas   
Mandrake A vulnerability has been discovered and corrected in automake: A race condition in automake (lib/am/distdir.am) could allow a local attacker to run arbitrary code with the privileges of the user running make distcheck (CVE-2012-3386). [More...]
 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:018
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : automake
 Date    : April 4, 2013
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 A vulnerability has been discovered and corrected in automake:
 
 A race condition in automake (lib/am/distdir.am) could allow a local
 attacker to run arbitrary code with the privileges of the user running
 make distcheck (CVE-2012-3386).
 
 The updated packages have been patched to correct this issue.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3386
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 d3d81ea5f344d0253504ebade7bf050f  mbs1/x86_64/automake-1.11.3-2.1.mbs1.noarch.rpm
 60b7ae1989d875a1b0d6cfd8363d746c  mbs1/x86_64/automake1.7-1.7.9-14.1.mbs1.noarch.rpm 
 7154fc724699ae697f2c8c199720a69b  mbs1/SRPMS/automake-1.11.3-2.1.mbs1.src.rpm
 7bf45296cd443808b262c92ece293be8  mbs1/SRPMS/automake1.7-1.7.9-14.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________