Gentoo: 201209-06 Expat: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo Multiple vulnerabilities have been found in Expat, possibly resulting in Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201209-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Expat: Multiple vulnerabilities
     Date: September 24, 2012
     Bugs: #280615, #303727, #407519
       ID: 201209-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Expat, possibly resulting
in Denial of Service.

Background
==========

Expat is a set of XML parsing libraries.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/expat            < 2.1.0_beta3           >= 2.1.0_beta3

Description
===========

Multiple vulnerabilities have been discovered in Expat. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to open a specially crafted XML
file in an application linked against Expat, possibly resulting in a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Expat users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/expat-2.1.0_beta3"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2009-3560
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3560
[ 2 ] CVE-2009-3720
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3720
[ 3 ] CVE-2012-0876
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0876
[ 4 ] CVE-2012-1147
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1147
[ 5 ] CVE-2012-1148
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1148

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201209-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5