Debian: 2445-1: typo3-src: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Debian Several remote vulnerabilities have been discovered in the TYPO3 web content management framework: CVE-2012-1606 [More...]
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2445-1                   security@debian.org
http://www.debian.org/security/                            Florian Weimer
March 31, 2012                         http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : typo3-src
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2012-1606 CVE-2012-1607 CVE-2012-1608

Several remote vulnerabilities have been discovered in the TYPO3 web
content management framework:

CVE-2012-1606 
	Failing to properly HTML-encode user input in several places,
	the TYPO3 backend is susceptible to Cross-Site Scripting. A
	valid backend user is required to exploit these
	vulnerabilities.

CVE-2012-1607
	Accessing a CLI Script directly with a browser may disclose
	the database name used for the TYPO3 installation.

CVE-2012-1608
	By not removing non printable characters, the API method
	t3lib_div::RemoveXSS() fails to filter specially crafted HTML
	injections, thus is susceptible to Cross-Site Scripting.

For the stable distribution (squeeze), these problems have been fixed in
version 4.3.9+dfsg1-1+squeeze3.

For the testing distribution (wheezy) and the unstable distribution
(sid), these problems have been fixed in version 4.5.14+dfsg1-1.

We recommend that you upgrade your typo3-src packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----