Ubuntu: 1351-1: AccountsService vulnerability
Posted by Benjamin D. Thomas   
Ubuntu AccountsService could be made to overwrite files as the administrator.
==========================================================================
Ubuntu Security Notice USN-1351-1
January 31, 2012

accountsservice vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 11.10

Summary:

AccountsService could be made to overwrite files as the administrator.

Software Description:
- accountsservice: query and manipulate user account information

Details:

Hayawardh Vijayakumar discovered that AccountsService incorrectly handled
privileges when modifying the language settings on Ubuntu. A local attacker
could exploit this issue to modify arbitrary files, and possibly create a
denial of service or obtain increased privileges.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 11.10:
  accountsservice                 0.6.14-1git1ubuntu1.1

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-1351-1
  CVE-2011-4406

Package Information:
  https://launchpad.net/ubuntu/+source/accountsservice/0.6.14-1git1ubuntu1.1