Gentoo: 201201-07: NX Server Free Edition, NX Node: Privilege escalation
Posted by Benjamin D. Thomas   
Gentoo An unspecified vulnerability in NX Server Free Edition and NX Nodecould allow local attackers to gain root privileges.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201201-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: NX Server Free Edition, NX Node: Privilege escalation
     Date: January 23, 2012
     Bugs: #378345
       ID: 201201-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An unspecified vulnerability in NX Server Free Edition and NX Node
could allow local attackers to gain root privileges.

Background
==========

NX Server Free Edition is a remote display technology by No Machine. NX
Node provides the shared components for NX Server.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-misc/nxserver-freeedition
                                 < 3.5.0.5                 >= 3.5.0.5
  2  net-misc/nxnode             < 3.5.0.4                 >= 3.5.0.4
    -------------------------------------------------------------------
     2 affected packages

Description
===========

NX Server Free Edition and NX Node use nxconfigure.sh, a setuid script
containing an unspecified vulnerability.

Impact
======

A local attacker could gain escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All NX Server Free Edition users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot -v ">=net-misc/nxserver-freeedition-3.5.0.5"

All NX Node users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.5.0.4"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 23, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2011-3977
      http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-3977

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201201-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5