Debian: 2378-1: ffmpeg: Multiple vulnerabilities
Posted by Benjamin D. Thomas   
Debian Several vulnerabilities have been discovered in ffmpeg, a multimedia player, server and encoder. Multiple input validations in the decoders for QDM2, VP5, VP6, VMD and SVQ1 files could lead to the execution of arbitrary code. [More...]
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2378-1                   security@debian.org
http://www.debian.org/security/                        Moritz Muehlenhoff
January 03, 2012                       http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : ffmpeg
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2011-4351 CVE-2011-4353 CVE-2011-4364 CVE-2011-4579 

Several vulnerabilities have been discovered in ffmpeg, a multimedia 
player, server and encoder. Multiple input validations in the decoders
for QDM2, VP5, VP6, VMD and SVQ1 files could lead to the execution of
arbitrary code.

For the stable distribution (squeeze), this problem has been fixed in
version 4:0.5.6-3.

For the unstable distribution (sid), this problem has been fixed in
version 4:0.7.3-1 of the libav source package.

We recommend that you upgrade your ffmpeg packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----