Gentoo: gedit Untrusted search path
Posted by Benjamin D. Thomas   
Gentoo A vulnerability in gedit might allow local attackers to execute arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200903-41
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: gedit: Untrusted search path
      Date: March 30, 2009
      Bugs: #257004
        ID: 200903-41

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability in gedit might allow local attackers to execute
arbitrary code.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

gedit is a text editor for the GNOME desktop.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-editors/gedit      < 2.24.3                     *>=3D 2.22.3-r1
                                                             >=3D 2.24.3

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

James Vega reported that gedit uses the current working directory when
searching for python modules, a vulnerability related to CVE-2008-5983.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could entice a user to open gedit from a specially
crafted environment, possibly resulting in the execution of arbitrary
code with the privileges of the user running the application.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Do not run gedit from untrusted working directories.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All gedit 2.22.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dapp-editors/gedit-2.22.3-r1"

All gedit 2.24.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dapp-editors/gedit-2.24.3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2008-5983
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-5983
  [ 2 ] CVE-2009-0314
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0314

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200903-41.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5