Gentoo: sudo Privilege escalation
Posted by Benjamin D. Thomas   
Gentoo A vulnerability in sudo may allow for privilege escalation.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200902-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: sudo: Privilege escalation
      Date: February 06, 2009
      Bugs: #256633
        ID: 200902-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability in sudo may allow for privilege escalation.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

sudo allows a system administrator to give users the ability to run
commands as other users.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package         /  Vulnerable  /                       Unaffected
    -------------------------------------------------------------------
  1  app-admin/sudo       < 1.7.0                             >=3D 1.7.0

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Harald Koenig discovered that sudo incorrectly handles group
specifications in Runas_Alias (and related) entries when a group is
specified in the list (using %group syntax, to allow a user to run
commands as any member of that group) and the user is already a member
of that group.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could possibly run commands as an arbitrary system
user (including root).

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All sudo users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dapp-admin/sudo-1.7.0"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2009-0034
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-0034

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200902-01.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5