Gentoo: Ampache Insecure temporary file usage
Posted by Benjamin D. Thomas   
Gentoo An insecure temporary file usage has been reported in Ampache, allowing for symlink attacks.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200812-22
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org/=

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Severity: Normal
       Title: Ampache: Insecure temporary file usage
        Date: December 23, 2008
        Bugs: #237483
          ID: 200812-22

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

An insecure temporary file usage has been reported in Ampache, allowing
for symlink attacks.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Ampache is a PHP based tool for managing, updating and playing audio
files via a web interface.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

      -------------------------------------------------------------------=

       Package           /  Vulnerable  /                     Unaffected
      -------------------------------------------------------------------=

    1  www-apps/ampache       < 3.4.3                           >=3D 3.4.=
3

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Dmitry E. Oboukhov reported an insecure temporary file usage within the
gather-messages.sh script.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could perform symlink attacks to overwrite arbitrary
files with the privileges of the user running the application.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Ampache users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=3Dwww-apps/ampache-3.4.3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    [ 1 ] CVE-2008-3929
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-3929

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200812-22.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5