Gentoo: Postfix Denial of Service
Posted by Benjamin D. Thomas   
Gentoo A memory leak in Postfix might allow local users to cause a Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200809-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org/=

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Severity: Normal
       Title: Postfix: Denial of Service
        Date: September 19, 2008
        Bugs: #236453
          ID: 200809-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A memory leak in Postfix might allow local users to cause a Denial of
Service.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Postfix is Wietse Venema's mailer that attempts to be fast, easy to
administer, and secure, as an alternative to the widely-used Sendmail
program.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

      -------------------------------------------------------------------=

       Package           /  Vulnerable  /                     Unaffected
      -------------------------------------------------------------------=

    1  mail-mta/postfix       < 2.4.9                           >=3D 2.4.=
9
                                                                >=3D 2.5.=
5
       mail-mta/postfix       < 2.5.5                           >=3D 2.4.=
9
                                                                >=3D 2.5.=
5

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

It has been discovered than Postfix leaks an epoll file descriptor when
executing external commands, e.g. user-controlled $HOME/.forward or
$HOME/.procmailrc files. NOTE: This vulnerability only concerns Postfix
instances running on Linux 2.6 kernels.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could exploit this vulnerability to reduce the
performance of Postfix, and possibly trigger an assertion, resulting in
a Denial of Service.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Allow only trusted users to control delivery to non-Postfix commands.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Postfix 2.4 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=3Dmail-mta/postfix-2.4.9"

All Postfix 2.5 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=3Dmail-mta/postfix-2.5.5"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    [ 1 ] CVE-2008-3889
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-3889

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200809-09.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5