Gentoo: Courier Authentication Library SQL injection
Posted by Benjamin D. Thomas   
Gentoo =3D=3D=3D=3D=3D=3D=3D=3D An SQL injection vulnerability has been discovered in the Courier Authentication Library.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200809-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                              http://security.gentoo.org/=

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Severity: Normal
       Title: Courier Authentication Library: SQL injection vulnerability=

        Date: September 05, 2008
        Bugs: #225407
          ID: 200809-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

An SQL injection vulnerability has been discovered in the Courier
Authentication Library.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The Courier Authentication Library is a generic authentication API that
encapsulates the process of validating account passwords.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

      -------------------------------------------------------------------=

       Package                   /  Vulnerable  /             Unaffected
      -------------------------------------------------------------------=

    1  net-libs/courier-authlib      < 0.60.6                  >=3D 0.60.=
6

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

It has been discovered that some input (e.g. the username) passed to
the library are not properly sanitised before being used in SQL
queries.

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could provide specially crafted input to the library,
possibly resulting in the remote execution of arbitrary SQL commands.
NOTE: Exploitation of this vulnerability requires that a MySQL database
is used for authentication and that a Non-Latin character set is
selected.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Courier Authentication Library users should upgrade to the latest
version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=3Dnet-libs/courier-authlib-0.60.6=
"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    [ 1 ] CVE-2008-2667
          http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-2667

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200809-05.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5