Gentoo: Python Multiple integer overflows
Posted by Benjamin D. Thomas   
Gentoo Multiple integer overflows may allow for Denial of Service.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200807-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Python: Multiple integer overflows
      Date: July 01, 2008
      Bugs: #216673, #217221
        ID: 200807-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

Multiple integer overflows may allow for Denial of Service.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Python is an interpreted, interactive, object-oriented programming
language.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package          /   Vulnerable   /                    Unaffected
    -------------------------------------------------------------------
  1  dev-lang/python      < 2.4.4-r13                     *>=3D 2.3.6-r6
                                                          >=3D 2.4.4-r13

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Multiple vulnerabilities were discovered in Python:

* David Remahl reported multiple integer overflows in the file
  imageop.c, leading to a heap-based buffer overflow (CVE-2008-1679).
  This issue is due to an incomplete fix for CVE-2007-4965.

* Justin Ferguson discovered that an integer signedness error in the
  zlib extension module might trigger insufficient memory allocation
  and a buffer overflow via a negative signed integer (CVE-2008-1721).

* Justin Ferguson discovered that insufficient input validation in
  the PyString_FromStringAndSize() function might lead to a buffer
  overflow (CVE-2008-1887).

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could exploit these vulnerabilities to cause a Denial
of Service or possibly the remote execution of arbitrary code with the
privileges of the user running Python.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The imageop module is no longer built in the unaffected versions.

All Python 2.3 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Ddev-lang/python-2.3.6-r6"

All Python 2.4 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Ddev-lang/python-2.4.4-r13"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2008-1679
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-1679
  [ 2 ] CVE-2008-1721
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-1721
  [ 3 ] CVE-2008-1887
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-1887

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200807-01.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5