Gentoo: Multiple X11 terminals Local privilege escalation
Posted by Benjamin D. Thomas   
Gentoo A vulnerability was found in aterm, Eterm, Mrxvt, multi-aterm, RXVT, rxvt-unicode, and wterm, allowing for local privilege escalation.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200805-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple X11 terminals: Local privilege escalation
      Date: May 07, 2008
      Bugs: #216833, #217819, #219746, #219750, #219754, #219760, #219762=

        ID: 200805-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A vulnerability was found in aterm, Eterm, Mrxvt, multi-aterm, RXVT,
rxvt-unicode, and wterm, allowing for local privilege escalation.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Aterm, Eterm, Mrxvt, multi-aterm, RXVT, rxvt-unicode, and wterm are X11
terminal emulators.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package                 /   Vulnerable   /             Unaffected
    -------------------------------------------------------------------
  1  x11-terms/aterm             < 1.0.1-r1                >=3D 1.0.1-r1
  2  x11-terms/eterm             < 0.9.4-r1                >=3D 0.9.4-r1
  3  x11-terms/mrxvt             < 0.5.3-r2                >=3D 0.5.3-r2
  4  x11-terms/multi-aterm       < 0.2.1-r1                >=3D 0.2.1-r1
  5  x11-terms/rxvt              < 2.7.10-r4              >=3D 2.7.10-r4
  6  x11-terms/rxvt-unicode       < 9.02-r1                 >=3D 9.02-r1
  7  x11-terms/wterm             < 6.2.9-r3                >=3D 6.2.9-r3
    -------------------------------------------------------------------
     7 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Bernhard R. Link discovered that Eterm opens a terminal on :0 if the
"-display" option is not specified and the DISPLAY environment variable
is not set. Further research by the Gentoo Security Team has shown that
aterm, Mrxvt, multi-aterm, RXVT, rxvt-unicode, and wterm are also
affected.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could exploit this vulnerability to hijack X11
terminals of other users.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All aterm users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/aterm-1.0.1-r1"

All Eterm users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/eterm-0.9.4-r1"

All Mrxvt users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/mrxvt-0.5.3-r2"

All multi-aterm users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/multi-aterm-0.2.1-r=
1"

All RXVT users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/rxvt-2.7.10-r4"

All rxvt-unicode users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/rxvt-unicode-9.02-r=
1"

All wterm users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dx11-terms/wterm-6.2.9-r3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2008-1142
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-1142
  [ 2 ] CVE-2008-1692
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-1692

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200805-03.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5