Mandriva: Updated wpa_supplicant package fixes remote
Posted by Benjamin D. Thomas   
Mandrake Stack-based buffer overflow in driver_wext.c in wpa_supplicant 0.6.0 allows remote attackers to cause a denial of service (crash) via crafted TSF data. Updated package fixes this issue.
 _______________________________________________________________________
 
 Mandriva Linux Security Advisory                         MDKSA-2007:245
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : wpa_supplicant
 Date    : December 13, 2007
 Affected: 2008.0
 _______________________________________________________________________
 
 Problem Description:
 
 Stack-based buffer overflow in driver_wext.c in wpa_supplicant
 0.6.0 allows remote attackers to cause a denial of service (crash)
 via crafted TSF data.
 
 Updated package fixes this issue.
 _______________________________________________________________________

 References:
 
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6025
 _______________________________________________________________________
 
 Updated Packages:
 
 Mandriva Linux 2008.0:
 80c2dc52d42fb324f6ff90fcfe02b9fa  2008.0/i586/wpa_gui-0.6.0-1.1mdv2008.0.i586.rpm
 0ec22d8e71719af986748a86ee4063ce  2008.0/i586/wpa_supplicant-0.6.0-1.1mdv2008.0.i586.rpm 
 18581ca13cf1758016bfaf52a0ea4992  2008.0/SRPMS/wpa_supplicant-0.6.0-1.1mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 677b536c2f630585c2df72a832aee497  2008.0/x86_64/wpa_gui-0.6.0-1.1mdv2008.0.x86_64.rpm
 0c87ce95a9432518480ccdc7eed168bb  2008.0/x86_64/wpa_supplicant-0.6.0-1.1mdv2008.0.x86_64.rpm 
 18581ca13cf1758016bfaf52a0ea4992  2008.0/SRPMS/wpa_supplicant-0.6.0-1.1mdv2008.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team