Foresight: libpng
Posted by Bill Keys   
Previous versions of the libpng package can cause applications to crash when loading malformed PNG files. It is not currently known that this vulnerability can be exploited to execute malicious code.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Foresight Linux Essential Advisory: 2007-0065-1
Published: 2007-11-11

Rating: Minor

Updated Versions:
   libpng=/conary.rpath.com@rpl:devel//1/1.2.22-1-0.1
   group-dist=/foresight.rpath.org@fl:1-devel//1/1.4.1-0.2-3

References:
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5266
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5267
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5268
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5269

Description:
   Previous versions of the libpng package can cause applications to
   crash when loading malformed PNG files.  It is not currently known
   that this vulnerability can be exploited to execute malicious code.

- ---

Copyright 2007 Foresight Linux Project
Portions Copyright 2007 rPath Inc.
This file is distributed under the terms of the MIT License.
A copy is available at http://www.foresightlinux.org/permanent/mit-license.html
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iQIVAwUBRzfbdNfwEn07iAtZAQJorQ//XpFcKedmytQceCut4A3lgvjh/FXUHlkh
wvU6CWI8B9jvDkmd5xH+kGsq+nsYe9VO7kcGDh634FqrAeCVuFFZED7p/IP1hQRC
jn7FZQV3vxS+R/iV22iySXKHy1309rOJVR6b2r/TwS0C0wer47CZZhTcnoGV0+TC
O13gl9MR1O0PsPnIEEU4Xts9mEGfELtnEDfvTxWFKGgzpIGxSXeL1xqFX1KjdjWb
HN8GuWDbjOjmawoj/S7nMX92nts65+IjaVEBbXyNz9K6Te8/BDqJM5XyLnAodoSI
+cJUp7qvr84uYQ602/QAsWkWKA7KHuh7E6/VZOvSp/9Y2H2zCHb+s8O6AvXHgo1z
iDkHLT9mSxh2LuykXt+f7WI1ltrPSKyOsckvh4hoiu234Cn9wbE8H/l6/0MtWrRZ
/e19dkcCJB3cKbBvc2mtzBIzhLMZ9JMCdduDLLvFAacRcjviNQCX+mu/OK6/fP9Y
1MzYD2C+s1wHnVL7nn5XU8+wByenTYlVy2v/azMuhNK1FTS0roYlnnvVThhQfTcg
E/ujxxpwFR5fS9SKP0zMzwOaA0eOQZ/fEHSdWD22cYhMIG7vUFiJ1i0cdRp0aETb
eV+LWSKB3i6fkFPYjDS6Dr4KCvsLbXiitDhfbzPVuuPsWkSLOvoIJb/skKoPGRGm
zh3T+TIN1mA=
=X58H
-----END PGP SIGNATURE-----