Gentoo: file Integer underflow
Posted by Benjamin D. Thomas   
Gentoo A buffer underflow vulnerability has been reported in file allowing for the user-assisted execution of arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200703-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: file: Integer underflow
      Date: March 30, 2007
      Bugs: #171452
        ID: 200703-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

A buffer underflow vulnerability has been reported in file allowing for
the user-assisted execution of arbitrary code.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

file is a utility that guesses a file format by scanning binary data
for patterns.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package        /  Vulnerable  /                        Unaffected
    -------------------------------------------------------------------
  1  sys-apps/file       < 4.20                                >=3D 4.20

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Jean-S=E9bastien Guay-Leroux reported an integer underflow in
file_printf function.

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could entice a user to run the "file" program on a
specially crafted file that would trigger a heap-based buffer overflow
possibly leading to the execution of arbitrary code with the rights of
the user running "file". Note that this vulnerability could be also
triggered through an automatic file scanner like amavisd-new.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Since file is a system package, all Gentoo users should upgrade to the
latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dsys-apps/file-4.20"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2007-1536
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2007-1536

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200703-26.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5