Mandriva: Updated perl-SOAP-Lite packages fix crash issue
Posted by Benjamin D. Thomas   
Mandrake SOAP::Lite makes use of auto-generated methods with names that clash with methods exported by UNIVERSAL::require. As a result, using the two modules simultaneously will result in an immediate program crash. The package has been patched with an upstream fix to correct the issue.

 _______________________________________________________________________
 
 Mandriva Linux Advisory                                   MDKA-2007:009
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : perl-SOAP-Lite
 Date    : January 15, 2007
 Affected: 2007.0
 _______________________________________________________________________
 
 Problem Description:
 
 SOAP::Lite makes use of auto-generated methods with names that clash
 with methods exported by UNIVERSAL::require.  As a result, using the
 two modules simultaneously will result in an immediate program crash.

 The package has been patched with an upstream fix to correct the issue.
 _______________________________________________________________________

 References:
 
 http://qa.mandriva.com/show_bug.cgi?id=27906
 _______________________________________________________________________
 
 Updated Packages:
 
 Mandriva Linux 2007.0:
 904bb5ab0672b5030ed67b4c127733e3  2007.0/i586/perl-SOAP-Lite-0.69-2.1mdv2007.0.noarch.rpm 
 3d1a51e8914a92c9618e1f30c8742bd9  2007.0/SRPMS/perl-SOAP-Lite-0.69-2.1mdv2007.0.src.rpm

 Mandriva Linux 2007.0/X86_64:
 4b4cc88bf4c76c106720cd81c904eeca  2007.0/x86_64/perl-SOAP-Lite-0.69-2.1mdv2007.0.noarch.rpm 
 3d1a51e8914a92c9618e1f30c8742bd9  2007.0/SRPMS/perl-SOAP-Lite-0.69-2.1mdv2007.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team