Gentoo: OpenOffice.org EMF/WMF file handling vulnerabilities
Posted by Benjamin D. Thomas   
Gentoo A truncation error and integer overflows in the EMF/WMF file handling of OpenOffice.org could be exploited to execute arbitrary code.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200701-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: OpenOffice.org: EMF/WMF file handling vulnerabilities
      Date: January 12, 2007
      Bugs: #159951
        ID: 200701-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A truncation error and integer overflows in the EMF/WMF file handling
of OpenOffice.org could be exploited to execute arbitrary code.

Background
==========

OpenOffice.org is an open source office productivity suite, including
word processing, spreadsheet, presentation, drawing, data charting,
formula editing, and file conversion facilities.

Affected packages
=================

    -------------------------------------------------------------------
     Package                    /  Vulnerable  /            Unaffected
    -------------------------------------------------------------------
  1  app-office/openoffice-bin       < 2.1.0                  >= 2.1.0
  2  app-office/openoffice           < 2.0.4                  >= 2.0.4
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

John Heasman of NGSSoftware has discovered integer overflows in the
EMR_POLYPOLYGON and EMR_POLYPOLYGON16 processing and an error within
the handling of META_ESCAPE records.

Impact
======

An attacker could exploit these vulnerabilities to cause heap overflows
and potentially execute arbitrary code with the privileges of the user
running OpenOffice.org by enticing the user to open a document
containing a malicious WMF/EMF file.

Workaround
==========

There is no known workaround known at this time.

Resolution
==========

All OpenOffice.org binary users should update to version 2.1.0 or
later:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/openoffice-bin-2.1.0"

All OpenOffice.org users should update to version 2.0.4 or later:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-office/openoffice-2.0.4"

References
==========

  [ 1 ] CVE-2006-5870
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5870

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200701-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5