Mandriva: Updated lirc packages fixes issue with dkms-lirc and SMP kernels
Posted by Benjamin D. Thomas   
Mandrake Dkms-lirc allows one to install LIRC drivers on non-Mandriva kernels. It contains a driver named lirc_parallel.ko which does not work on SMP-enabled kernels, preventing the driver installation on such kernels. The lirc_parallel.ko driver has been removed from the updated package and moved to a separate package named dkms-lirc-parallel.
 _______________________________________________________________________
 
 Mandriva Linux Advisory                                   MDKA-2007:007
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : lirc
 Date    : January 11, 2007
 Affected: 2007.0
 _______________________________________________________________________
 
 Problem Description:
 
 Dkms-lirc allows one to install LIRC drivers on non-Mandriva kernels.
 It contains a driver named lirc_parallel.ko which does not work on
 SMP-enabled kernels, preventing the driver installation on such
 kernels. The lirc_parallel.ko driver has been removed from the updated
 package and moved to a separate package named dkms-lirc-parallel.
 _______________________________________________________________________

 References:
 
 http://qa.mandriva.com/show_bug.cgi?id=26979
 _______________________________________________________________________
 
 Updated Packages:
 
 Mandriva Linux 2007.0:
 bffa111cd415587bde4d9eacb19d5c4b  2007.0/i586/dkms-lirc-0.8.1-0.20060722.4.2mdv2007.0.i586.rpm
 84e97c4b8268dc8edc9ef3ee9bc10a37  2007.0/i586/dkms-lirc-parallel-0.8.1-0.20060722.4.2mdv2007.0.i586.rpm
 c18f5876114aefa53af4e94d5dade5fc  2007.0/i586/liblirc0-0.8.1-0.20060722.4.2mdv2007.0.i586.rpm
 fce646fa599cda3c8ca348e04c758e03  2007.0/i586/liblirc0-devel-0.8.1-0.20060722.4.2mdv2007.0.i586.rpm
 2c88f47f6fd101926ad08c55e8989763  2007.0/i586/lirc-0.8.1-0.20060722.4.2mdv2007.0.i586.rpm 
 992bcd0113f6319d7809e35930bc6eca  2007.0/SRPMS/lirc-0.8.1-0.20060722.4.2mdv2007.0.src.rpm

 Mandriva Linux 2007.0/X86_64:
 6489fc348424092b301278bb2351916f  2007.0/x86_64/dkms-lirc-0.8.1-0.20060722.4.2mdv2007.0.x86_64.rpm
 60c562ecdc10211a2fa616b3aff5af10  2007.0/x86_64/dkms-lirc-parallel-0.8.1-0.20060722.4.2mdv2007.0.x86_64.rpm
 5d73311357cf36df1bb2da3230be4905  2007.0/x86_64/lib64lirc0-0.8.1-0.20060722.4.2mdv2007.0.x86_64.rpm
 9eec740f3886f786dc4bb1effe6b43dd  2007.0/x86_64/lib64lirc0-devel-0.8.1-0.20060722.4.2mdv2007.0.x86_64.rpm
 fb167951e59f6bed663696fdcda033c0  2007.0/x86_64/lirc-0.8.1-0.20060722.4.2mdv2007.0.x86_64.rpm 
 992bcd0113f6319d7809e35930bc6eca  2007.0/SRPMS/lirc-0.8.1-0.20060722.4.2mdv2007.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team