Mandriva: Updated squirrelmail packages fix vulnerabilities
Posted by Benjamin D. Thomas   
Mandrake Webmail.php in SquirrelMail 1.4.0 to 1.4.5 allows remote attackers to inject arbitrary web pages into the right frame via a URL in the right_frame parameter. NOTE: this has been called a cross-site scripting (XSS) issue, but it is different than what is normally identified as XSS. (CVE-2006-0188)
 _______________________________________________________________________
 
 Mandriva Linux Security Advisory                         MDKSA-2006:049
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : squirrelmail
 Date    : February 27, 2006
 Affected: Corporate 3.0
 _______________________________________________________________________
 
 Problem Description:
 
 Webmail.php in SquirrelMail 1.4.0 to 1.4.5 allows remote attackers to
 inject arbitrary web pages into the right frame via a URL in the
 right_frame parameter. NOTE: this has been called a cross-site
 scripting (XSS) issue, but it is different than what is normally
 identified as XSS. (CVE-2006-0188)
 
 Interpretation conflict in the MagicHTML filter in SquirrelMail 1.4.0
 to 1.4.5 allows remote attackers to conduct cross-site scripting (XSS)
 attacks via style sheet specifiers with invalid (1) "/*" and "*/"
 comments, or (2) a newline in a "url" specifier, which is processed by
 certain web browsers including Internet Explorer. (CVE-2006-0195)
 
 CRLF injection vulnerability in SquirrelMail 1.4.0 to 1.4.5 allows
 remote attackers to inject arbitrary IMAP commands via newline
 characters in the mailbox parameter of the sqimap_mailbox_select
 command, aka "IMAP injection." (CVE-2006-0377)
 
 Updated packages are patched to address these issues.
 _______________________________________________________________________

 References:
 
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0188
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0195
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0377
 _______________________________________________________________________
 
 Updated Packages:
 
 Corporate 3.0:
 a8a4f0d87a51ad6507b022d0969090b7  corporate/3.0/RPMS/squirrelmail-1.4.5-1.2.C30mdk.noarch.rpm
 4c2c56ffffe0613d8357dc3f3b83558b  corporate/3.0/RPMS/squirrelmail-poutils-1.4.5-1.2.C30mdk.noarch.rpm
 ffab86ae7438d6f23bd934d17d38c41f  corporate/3.0/SRPMS/squirrelmail-1.4.5-1.2.C30mdk.src.rpm

 Corporate 3.0/X86_64:
 ef2a5ee98b793f81be3e87ec8efb1f30  x86_64/corporate/3.0/RPMS/squirrelmail-1.4.5-1.2.C30mdk.noarch.rpm
 cf91cf6ca3f2bd737b475a1037a521ef  x86_64/corporate/3.0/RPMS/squirrelmail-poutils-1.4.5-1.2.C30mdk.noarch.rpm
 ffab86ae7438d6f23bd934d17d38c41f  x86_64/corporate/3.0/SRPMS/squirrelmail-1.4.5-1.2.C30mdk.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team