Gentoo: VMware Workstation Vulnerability in NAT networking
Posted by Benjamin D. Thomas   
Gentoo VMware guest operating systems can execute arbitrary code with elevated privileges on the host operating system through a flaw in NAT networking.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200601-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: VMware Workstation: Vulnerability in NAT networking
      Date: January 07, 2006
      Bugs: #116238
        ID: 200601-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

VMware guest operating systems can execute arbitrary code with elevated
privileges on the host operating system through a flaw in NAT
networking.

Background
==========

VMware Workstation is a powerful virtual machine for developers and
system administrators.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /    Vulnerable    /               Unaffected
    -------------------------------------------------------------------
  1  vmware-workstation      < 5.5.1.19175              >= 5.5.1.19175
                                                       *>= 4.5.3.19414

Description
===========

Tim Shelton discovered that vmnet-natd, the host module providing
NAT-style networking for VMware guest operating systems, is unable to
process incorrect 'EPRT' and 'PORT' FTP requests.

Impact
======

Malicious guest operating systems using the NAT networking feature or
local VMware Workstation users could exploit this vulnerability to
execute arbitrary code on the host system with elevated privileges.

Workaround
==========

Disable the NAT service by following the instructions at
http://www.vmware.com/support/kb, Answer ID 2002.

Resolution
==========

All VMware Workstation users should upgrade to a fixed version:

    # emerge --sync
    # emerge --ask --oneshot --verbose app-emulation/vmware-workstation

References
==========

  [ 1 ] CVE-2005-4459
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4459
  [ 2 ] VMware Security Response
        http://www.vmware.com/support/kb/enduser/std_adp.php?p_faqid=2000

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200601-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0